Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12499 closed defect (fixed)

Pidgin shows incorrect status for XMPP buddy

Reported by: ladar Owned by: darkrain42
Milestone: 2.7.4 Component: XMPP
Version: 2.7.3 Keywords:
Cc:

Description (last modified by ladar)

If you add your own account to your buddy list, it will show up offline even when you are online. As you can see from screenshot, a hover or get info will yield the correct status information, but the buddy list remains incorrect.

If I sign in from Empathy I show up online in Pidgin. And if I sign off from Empathy, I continue to show up online in Pidgin.

Attachments (3)

xmpp-problem.png (42.5 KB) - added by ladar 9 years ago.
xmpp-after-empathy.png (13.0 KB) - added by ladar 9 years ago.
debug.log (227.8 KB) - added by ladar 9 years ago.
requested debug log file

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by ladar

  • Description modified (diff)

Changed 9 years ago by ladar

Changed 9 years ago by ladar

comment:2 Changed 9 years ago by darkrain42

  • Keywords status removed
  • Status changed from new to pending

What version of Pidgin and libpurple does Help->About report?

comment:3 Changed 9 years ago by ladar

  • Status changed from pending to new

Pidgin 2.7.3 (libpurple 2.7.3)

comment:4 Changed 9 years ago by darkrain42

  • Owner changed from deryni to darkrain42

comment:5 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
Please get a full debug log of signing in to your account, adding yourself to your buddy list, signing in to Empathy, and then signing out of Empathy

Changed 9 years ago by ladar

requested debug log file

comment:6 Changed 9 years ago by ladar

  • Status changed from pending to new

Attachment (debug.log) added by ticket reporter.

comment:8 Changed 9 years ago by ladar

Requested debug file attached. If it helps, you can create a free account on lavabit.com and test it out yourself...

comment:9 Changed 9 years ago by ladar

P.S. I suspect the issue is related to how resource identifiers are handled. Since a hover shows the "portable" resource as available but the non-specific xmpp id is marked offline.

comment:10 Changed 8 years ago by darkrain42@…

  • Milestone set to 2.7.4
  • Resolution set to fixed
  • Status changed from new to closed

(In c69bc8e83c4645b4d8a7a4fefcc17d822d988de3):
jabber: Set a connection display name even when using legacy auth

Previously, the only place we were setting one was in the bind-result code path, so it was always NULL when doing legacy auth, but that causes issues with jabber_presence_fake_to_self, so let's just have a default init in jabber_stream_new(). Should Fixes #12499

comment:11 Changed 8 years ago by darkrain42

ladar, I was unable to test this because lavabit has disabled sign-ups. Please test with 2.7.4 when it is released and comment here if it's still not working for you.

comment:12 Changed 8 years ago by ladar

I sent you an IM with test credentials, but thought you should also know, Lavabit is using jabberd 2.2.11, so you might be able to reproduce the problem by setting up that server daemon...

comment:13 Changed 8 years ago by darkrain42

Belatedly got around to testing this with the provided credentials, and it seems to be working fine now (confirmed broken in Adium (old libpurple) and fixed in Finch 2.7.4devel).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!