Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12593 closed defect (fixed)

ICQ Contact tooltip Status text probably not escaped correctly

Reported by: thomas001 Owned by: MarkDoliner
Milestone: 2.7.5 Component: ICQ
Version: 2.7.3 Keywords:
Cc:

Description

Hello, some of my icq contacts use the famous "<3" in there status messages. This is correctly shown right below the nick in the contact list, but when hovering the nick in the contact list, so that extended informations in a tooltip appear the status text ends right before the "<3". Looks really like some HTML escaping is missing here.

Change History (6)

comment:1 Changed 8 years ago by Robby

  • Component changed from pidgin (gtk) to ICQ
  • Owner set to MarkDoliner

comment:2 Changed 8 years ago by Robby

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11964.
Correct me if I'm wrong but this looks like #11964.

comment:3 Changed 8 years ago by ivan.komarov

Yes, I think that's a duplicate; thanks for pointing that out. My fix for that is still in my CPW branch, and I'll try to merge it to ipp ASAP.

comment:4 Changed 8 years ago by Robby

Cool! :)

comment:5 Changed 8 years ago by ivan.komarov@…

  • Milestone set to 2.7.5
  • Resolution changed from duplicate to fixed

(In 59e16ff94a4636665de90332c92822e35d063b2b):
Merged my changes that fix #11964 and #12593. Mark looked over them and said they looked good to him.

applied changes from 7b998c02b684a694f1089bee715e4a3952bbcf08

through 563c6a79e1266b750fe4bd608890195cfbcd8a2c

comment:6 Changed 8 years ago by rekkanoryo@…

(In f66a462582d88603680b07482658645162a98ed5):
ChangeLog some stuff that should have been, but wasn't. Refs #12810, #11964, #12593, #12768, #12781.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!