Opened 8 years ago

Last modified 8 years ago

#12642 new defect

finch problem with connectbot Android with ALT key

Reported by: asampau Owned by: sadrul
Milestone: Component: finch (gnt/ncurses)
Version: 2.7.3 Keywords: finch connectbot
Cc: asampau@…, livnah

Description

This issue is explained at https://code.google.com/p/connectbot/issues/detail?id=349#c3. It seems to be a finch problem, not a Connectbot issue. I tried to locate maptimeout value, by adding in ~/.screenrc but didn't work. Thanks in advance.

Change History (3)

comment:1 Changed 8 years ago by rekkanoryo

Using a Motorola Droid and ConnectBot 1.7.0, I was only able to reproduce your problem about half the time with alt+n and alt+p. I could not reproduce it at all with alt+c or alt+q despite several attempts to do so.

I also tried running in screen, and I could not reproduce the problem at all with screen, even without changing the maptimeout setting.

comment:2 Changed 8 years ago by asampau

Try to reproduce using Connectbot with VirtualKeyboard?, so I have Samsung Galaxy i5700 (Spica) with Android 1.5, has not Physical Keyboard.

comment:3 Changed 8 years ago by livnah

Reproduced problem with Dell Streak (no hardware keyboard, no trackball, Android 2.2 Froyo) connecting to NetBSD & FC14 (both) running Finch 2.7.3...

Please see my new post on the link provided with the ticket description. Using a few custom lines in ~/.screenrc it's possible to work around the problem. It'd be nice if future versions of finch didn't use anything higher than F9 as most mobile devices are F2-F9 only (F3 and F9 are already mapped, hence why I used F5 and F6). I can also report that the finch manpage indicating Ctrl-O works as F10 is NOT functioning; Ctrl-O does nothing (in 2.7.3 at least).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!