Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12768 closed defect (fixed)

error unable to send message message is too large in chat when only typing...hiya

Reported by: TwilightFireguard Owned by: markdoliner
Milestone: 2.7.5 Component: AIM
Version: 2.7.4 Keywords: too long message
Cc: jstricker, USP45, amejr999, Daioh

Description

Every time i try to get into a chat, i have no problem entering the room. the problem i have is being able to actually chat in the room. no matter what i type whether it's hiya or hey how are you doing, i get the same error message:: (3:00:40 AM) Unable to send message: The message is too large... i'm not typing anything beyond normal boundries of an IM.. i mean like two or three letters at most but it still gives me that message. can you tell me how to fix this? i ahven't downloaded any plugins at all for pidgin.

Change History (16)

comment:1 Changed 8 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
Which protocol (AIM/Yahoo/MSN/XMPP/etc.) are you seeing this with?

comment:2 Changed 8 years ago by jstricker

I'm seeing this issue as well after upgrading from 2.7.3 to 2.7.4. I asked a coworker to upgrade his Pidgin installation from 2.7.3 (which was working in chat rooms) to 2.7.4 and he's also seeing this behavior now. Here's what the debug log shows:

(10:15:35) oscar: Could not send 1 because (1 > maxlen 0) or (1 > maxvis 0)
(10:15:35) oscar: Could not send 2 because (1 > maxlen 0) or (1 > maxvis 0)
(10:15:36) oscar: Could not send 3 because (1 > maxlen 0) or (1 > maxvis 0)
(10:15:36) oscar: Could not send 4 because (1 > maxlen 0) or (1 > maxvis 0)
(10:15:41) oscar: Could not send test because (4 > maxlen 0) or (4 > maxvis 0)

comment:3 Changed 8 years ago by datallah

  • Component changed from unclassified to AIM

comment:4 Changed 8 years ago by datallah

Ticket #12779 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by rekkanoryo

  • Owner changed from rekkanoryo to markdoliner

comment:6 Changed 8 years ago by amejr999

I'm having the issue also, it started when I upgraded to 2.7.4.

comment:7 Changed 8 years ago by ivan.komarov@…

  • Milestone set to 2.7.5
  • Resolution set to fixed
  • Status changed from pending to closed

(In 9f1343307fd654c231ff7ec66adbd8a8fd3fdbfb):
Ouch, I accidentally removed too much code in b367bdaac1f79166db0e9478ae30e2a7628f6848. Fixes #12768.

comment:8 Changed 8 years ago by ivan.komarov

My bad, guys, I inadvertently broke this in 2.7.4. The fix should be included in the next release.

comment:9 Changed 8 years ago by Daioh

It's not fixed if there's no fix yet, is it?... I accidentally made a duplicate ticket bacuase of this (closed it as well :) ) Lack of this function completely breaks 2.7.4 for me. Had to downgrade to 2.7.3 to keep Pidgin usable for me.

comment:10 Changed 8 years ago by MarkDoliner

We generally close tickets when the fix is checked in, rather than when the fix is released. The "milestone" field can be used to determine if the fix is in a released version or not.

comment:11 Changed 8 years ago by Daioh

ETA of 2.7.5? :P

comment:12 Changed 8 years ago by rekkanoryo

When it's ready.

comment:13 Changed 8 years ago by ivan.komarov

Ticket #12803 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by ivan.komarov

Ticket #12802 has been marked as a duplicate of this ticket.

comment:15 Changed 8 years ago by datallah

There is a libpurple.dll attached to #12778 that also contains the fix for this issue in case anyone is interested.

comment:16 Changed 8 years ago by rekkanoryo@…

(In f66a462582d88603680b07482658645162a98ed5):
ChangeLog some stuff that should have been, but wasn't. Refs #12810, #11964, #12593, #12768, #12781.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!