Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12945 closed defect (fixed)

2.7.6 MSN invisible doesn't work

Reported by: djsolidsnake86 Owned by: QuLogic
Milestone: 2.7.8 Component: MSN
Version: 2.7.6 Keywords:
Cc:

Description

in new version, invisible mode does not work, my contact see me as invisible (using both msn or pidgin) and also me in my list seem online and not invisible (i've added my contat to my list for see the status)

Attachments (2)

purple-debug-switching-to-online.log (1.7 KB) - added by foutrelis 8 years ago.
purple-debug-switching-to-invisible.log (1.7 KB) - added by foutrelis 8 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by rekkanoryo

  • Component changed from unclassified to MSN
  • Owner changed from rekkanoryo to QuLogic

comment:2 Changed 8 years ago by QuLogic

  • Status changed from new to pending

Are you sure you're Invisible and didn't just pick an Available status with the message "Invisible"?

It works fine for me, whether I change to Invisible somewhere in between, or login Invisible from the beginning.

comment:3 Changed 8 years ago by djsolidsnake86

  • Status changed from pending to new

yes i'm sure that i'm in a invisible status, but other contacts see me (as invisible but they see me :S )

comment:4 Changed 8 years ago by QuLogic

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:5 Changed 8 years ago by Dimmuxx

Ticket #12983 has been marked as a duplicate of this ticket.

Changed 8 years ago by foutrelis

Changed 8 years ago by foutrelis

comment:6 Changed 8 years ago by foutrelis

I'm noticing the same behavior too. I have my own contact in my contact list and it just continues to appear as "Online", even after I've switched my status to "Invisible".

I have attached the debug logs from when switching from online to invisible and back.

comment:7 Changed 8 years ago by QuLogic

Looking at that log, I can see there is a bug when you are on your own list, but are you sure other people see you as available?

comment:8 Changed 8 years ago by qulogic@…

(In e010a6a5ac862c38a6a99db5b6981a985f9b7fb6):
Add the HDN status to status parsing, which means invisible, but you'd only see it if you had yourself on your own list.

Refs #12945.

comment:9 Changed 8 years ago by foutrelis

You fixed it before I was even able to comment. Awesome and thanks. :)

(Message I was going to post follows.)

I tested with another account, and your hint seems to be spot-on! When I set my status to Invisible, the other account sees me as being offline whereas I see me as Online on my contact list. As you mentioned, this is a bug and you are able to confirm it, right?

(By the way, I forgot the mention the Pidgin version I'm running; it's 2.7.7.)

comment:10 Changed 8 years ago by rekkanoryo

  • Milestone set to 2.7.8
  • Resolution set to fixed
  • Status changed from pending to closed

Given the comments here, I believe QuLogic has fixed this bug.

comment:11 Changed 8 years ago by qulogic@…

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!