Opened 8 years ago

Closed 8 years ago

#12973 closed defect (fixed)

MSN will no longer change/display own buddy icon.

Reported by: Cobalt Owned by: QuLogic
Milestone: 2.7.8 Component: MSN
Version: 2.7.6 Keywords: MSN icon GTK buddy list
Cc: salinasv, bwRavencl

Description

Hello.

As discussed, here's the bug report.

Some background: I upgraded from 2.7.3 to 2.7.6 on Ubuntu Karmic. I compiled 2.7.6 from the directory tree of 2.7.3 (official PPA sources), and used 2.7.6 tarball from pidgin.im. This compiled mostly without hassle, after issuing autoreconf -fi (I built packages).

The problem is this: When I click on the change icon button at the bottom of the buddy list, and choose an icon, MSN does not update the icon. If there was an icon there previously, it is set to blank, for MSN, even though the proper icon shows up in the 'accounts' dialog. The same happens whether it's a 32-bit PNG with alpha transparency, or a 24-bit JPG. I have attached a verbose log whilst this has been going on. The only account that was enabled at the time was the MSN account. I am included on my own buddy list.

Further possibly related issues: The first protocol to change is Yahoo, followed by XMPP. It does not work for Facebook, which, I take it has not implemented the feature of changing icons. I'm not a 100% sure, but I think that in 2.7.3, XMPP did not lag all that much. I may be able to provide more information on this if you direct me towards it.

Attachments (1)

purple-debug.log (52.5 KB) - added by Cobalt 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Cobalt

comment:1 follow-up: Changed 8 years ago by Dimmuxx

  • Component changed from pidgin (gtk) to MSN
  • Owner set to QuLogic

Fetching other people's buddy icons doesn't work either.

comment:2 in reply to: ↑ 1 Changed 8 years ago by sillern

Replying to Dimmuxx:

Fetching other people's buddy icons doesn't work either.

Is there a fix planned for this, it must be a regression right?

Fetching avatars worked before, I don't know when it stopped working though.

Is there more information needed to fix this maybe?

comment:3 Changed 8 years ago by QuLogic

Ticket #12998 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by qulogic@…

  • Milestone set to 2.7.8
  • Resolution set to fixed
  • Status changed from new to closed

(In 4220a157ee1e37ad605df13d61e9891ef996f6d7):
Add the session user to the userlist. This reduces the amount of special-casing needed and corrects the buddy icon if you have yourself on your list.

Fixes #12973.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!