Opened 6 years ago

Closed 11 months ago

#13012 closed defect (out of date)

MSN message send fails - "Message could not be sent because we were unable to establish a session with the server. This is likely a server problem, try again in a few minutes:"

Reported by: holk Owned by: EionRobb
Milestone: Component: MSN
Version: 2.7.7 Keywords:
Cc: oyvind, sandkiller, nazgul

Description

Since a while back (about the same time as v2.7.7 appeared), I cannot send messages over MSN. I can see my buddies, but no message sending. Also, my buddies cannot send to me.

When I try to send something, I get the rely (in red): "Message could not be sent because we were unable to establish a session with the server. This is likely a server problem, try again in a few minutes:"

I attach a log, slightly anonymized.

Per

Attachments (1)

Pidgin-error-29Nov2010.txt (1.9 KB) - added by holk 6 years ago.

Download all attachments as: .zip

Change History (21)

Changed 6 years ago by holk

comment:1 Changed 6 years ago by oyvind

I have the exact same problem. After upgrading to versjon 2.7.7, I am no longer able to send or receive messages over MSN.

I'm behind a proxy and use the "Use HTTP Method" setting. HTTP Method Server: gateway.messenger.hotmail.com

comment:2 Changed 6 years ago by holk

Further comments: I have been in contact with several colleagues also using Pidgin, and they all report the same problem. We are all in the same company, behind the same firewall.

I realize that I need to check whether the problem exists outside the firewall. Stay tuned.

comment:3 Changed 6 years ago by QuLogic

  • Component changed from unclassified to MSN
  • Keywords MSN send fails removed
  • Status changed from new to pending

It seems to me your company has a proxy that doesn't understand the new MSN protocol.

comment:4 Changed 6 years ago by holk

  • Status changed from pending to new

@QuLogic,

Hi, and thanks for your comment.

I am surprised that a change in the MSN protocol affects the HTTP tunneled traffic. I was under the impression that a web proxy does not need to understand the internals of the tunneled traffic.

What can I do to resolve this situation?

comment:5 Changed 6 years ago by jmanig

I have the same issue. The official client runs fine behind my corporate firewall -- I've been using it for years until my workstation got converted to Linux. Pidgin running MSNP16 does not. MSNP15 is fine. My logs are identical to what holk posted.

Let me know if there's any testing I can do to help.

comment:6 Changed 6 years ago by solomon

Another 2.7.5 -> 2.7.7 datapoint here, also behind a corporate firewall. Same error message on any attempt to send MSN data - via HTTP proxy. I can try SOCKS and see if that improves things any - will report here.

comment:7 Changed 6 years ago by solomon

Correction to previous report - I was already using SOCKS proxy, not HTTP proxy.

Additional data: I modified my MSN account Advanced page and unchecked "Use HTTP Method". I'm able to communicate via MSN now.

comment:8 Changed 6 years ago by sandkiller

Same issue happens here.

Suggestion from previous user (solomon) did not work with me, after untick the box of "use http method" the message shows and I cannot login: "Connection error from Notification server: Access denied: HTTP proxy server forbids port 1863 tunneling"

configuration: server: messenger.hotmail.com port: 1863 proxy type: http

If i change to SOCKS4 the following message shows: "Connection error from Notification server: No error"

With SOCKS5 it keeps forever trying to connect and nothing happens...

comment:9 Changed 6 years ago by nazgul

Same issue here: using environmental proxy settings messenger.hotmail.com, port 1863, http method, gateway.messenger.hotmail.com, versions 2.7.7 and 2.7.8

comment:10 follow-up: Changed 6 years ago by husey

It worked for me using http://code.google.com/p/msn-pecan/ protocol instead of built in MSN protocol. Versions tested 2.7.8 and 2.7.9. I left all configurations by default with "Use HTTP Method" option checked.

Hope this helps.

comment:11 in reply to: ↑ 10 Changed 6 years ago by jmanig

Replying to husey:

It worked for me using http://code.google.com/p/msn-pecan/ protocol instead of built in MSN protocol. Versions tested 2.7.8 and 2.7.9. I left all configurations by default with "Use HTTP Method" option checked.

Hope this helps.

From reading my logs, msn-pecan doesn't seem to do MSNP16 at all, which is why it works.

comment:12 Changed 6 years ago by goddert

Same issue here

Working with http proxy open on ports 80/443. Definitly worked before 2.7.7. It works without proxy.

@Qulogic A proxy doesn't have to understand anything of a MSN/Gtalk-or-else protocol. It tunnels nothing else.

comment:13 Changed 6 years ago by thorin

I have the same problem. Msn-pecan installation fix it.

comment:14 Changed 6 years ago by rhduncan

Same issue here, and seems to be a problem in 2.7.10 too

comment:15 Changed 6 years ago by jmanig

Well, I managed to make a little bit of progress.

Differences with the official client:

  • The official client uses an encoding of text/xml and not application/x-ms-messenger
  • The official client uses a User-Agent line of Mozilla/4.0 (Compatible; blah blah blah)
  • The official client sends a GUID surrounded by XML encoded braces.

If I try text/xml and User-Agent -> Mozilla/4.0 (just that), the server responds but reading the socket fails, which gets us a *bit* further. But changing it to the exact same thing MSN sends gets me back to the same error.

I can't change the GUID string without bypassing glib, so I haven't tried that yet.

comment:16 Changed 6 years ago by goddert

Any progress? This bug exists since four versions ...

comment:17 Changed 5 years ago by goddert

Would be kind to know if someone is working on this or whether it is completely abandoned. Maybe the problem is not widespread but in any case it continues to exist and makes Pidgin unusable for a lot of people behind a proxy. Thanks for your attention

comment:18 Changed 5 years ago by seandlh

I can still report this is an issue in 2.10.4 when using a HTTP proxy with Gentoo Linux. I am having trouble using version 0.1.3 of msn-pecan, so that is not a work-around.

comment:19 Changed 3 years ago by rekkanoryo

  • Owner changed from rekkanoryo to EionRobb

comment:20 Changed 11 months ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

This is a switchboard server related problem, and switchboard servers don't exist anymore. Closing

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!