Opened 9 years ago

Closed 9 years ago

#13048 closed defect (fixed)

XMPP: Jingle: ack but no session-accept, Error parsing content

Reported by: jonkri Owned by: malu
Milestone: 2.7.8 Component: XMPP
Version: 2.7.7 Keywords:
Cc:

Description

I send the following XML to my XMPP account trying to initiate a Jingle File Transfer:

<iq from='test1@mehdi-laptop/pontarius-transfer' to='test@mehdi-laptop/pidgin' type='set' id='session-995520984'>
	<jingle action='session-initiate' initiator='sender' sid='sessionid25' xmlns='urn:xmpp:jingle:1'>
		<content creator='initiator' name='file'>
			<description xmlns='urn:xmpp:jingle:apps:file-transfer:1'>
				<offer>
					<file hash='01234567890123456789' name='test.txt' size='10' xmlns='http://jabber.org/protocol/si/profile/file-transfer'/>
				</offer>
			</description>
			<transport block-size='4096' sid='sessionid24' xmlns='urn:xmpp:jingle:transports:ibb:1'/>
		</content>
	</jingle>
</iq>

I get an acknowledgement but nothing else, and the log says:

(18:42:03) jabber: Recv (ssl)(145): <presence from='test1@mehdi-laptop/pontarius-transfer' to='test@mehdi-laptop/pidgin' id='session-3612737608'><status>Transfer</status></presence>
(18:42:03) blist: Updating buddy status for test1@mehdi-laptop (XMPP)
(18:42:03) pidgin-libnotify: notify(), new: title: 'test1@mehdi-laptop', body: 'is online', buddy: 'test1@mehdi-laptop'
(18:42:03) pidgin-libnotify: notify(), has a prpl icon.
(18:42:03) jabber: Recv (ssl)(572): <iq from='test1@mehdi-laptop/pontarius-transfer' to='test@mehdi-laptop/pidgin' type='set' id='session-995520984'><jingle action='session-initiate' initiator='sender' sid='sessionid25' xmlns='urn:xmpp:jingle:1'><content creator='initiator' name='file'><description xmlns='urn:xmpp:jingle:apps:file-transfer:1'><offer><file hash='01234567890123456789' name='test.txt' size='10' xmlns='http://jabber.org/protocol/si/profile/file-transfer'/></offer></description><transport block-size='4096' sid='sessionid24' xmlns='urn:xmpp:jingle:transports:ibb:1'/></content></jingle></iq>
(18:42:03) jabber: got Jingle package action = session-initiate
(18:42:03) jingle: find_by_id sessionid25
(18:42:03) jingle: lookup: (nil)
(18:42:03) jingle: inserting session with key: sessionid25 into table
(18:42:03) jingle: Error parsing content
(18:42:03) jabber: Sending (ssl) (test@mehdi-laptop/pidgin): <iq type='result' id='session-995520984' from='test@mehdi-laptop/pidgin' to='test1@mehdi-laptop/pontarius-transfer'/>

See: http://xmpp.org/extensions/xep-0166.html and http://xmpp.org/extensions/xep-0234.html for more information about the relevant Jingle specs.

Change History (3)

comment:1 Changed 9 years ago by darkrain42

  • Component changed from unclassified to XMPP
  • Owner changed from rekkanoryo to malu

Marcus: He is running 2.6.6, but my thinking was that we should be responding with some sort of error if we can't handle the content-type? (I'm also not familiar enough with Jingle to say definitively)

comment:2 Changed 9 years ago by jonkri

  • Version changed from 2.6.6 to 2.7.7

The problem is the same in 2.7.7.

I believe you are correct rekkanoryo, see http://xmpp.org/extensions/xep-0166.html#protocol-response-errors.

comment:3 Changed 9 years ago by malu@…

  • Milestone set to 2.7.8
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!