Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13165 closed defect (fixed)

My AIM icon won't display.

Reported by: magari Owned by: MarkDoliner
Milestone: 2.8.0 Component: AIM
Version: 2.7.9 Keywords:
Cc:

Description

No matter what I do, I can't make my own AIM buddy icon display. I can't see it on my own buddy list, nor can others see it on theirs or when I IM them. I have chosen and saved one, which I can see when I go to "edit account", and the "use this buddy icon for this account" box is checked. I've even tried setting the global icon, and that isn't showing up either. What am I missing?

Attachments (2)

debug.log (24.7 KB) - added by magari 8 years ago.
jae4.jpg (21.5 KB) - added by magari 8 years ago.
icon example

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by deryni

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

Specifically get the debug log output from when you set the buddy icon for your account (or globally) and (possibly) from when you log in to your account.

Changed 8 years ago by magari

comment:2 Changed 8 years ago by magari

  • Status changed from pending to new

Attachment (debug.log) added by ticket reporter.

comment:4 Changed 8 years ago by magari

I just tried using a smaller icon because I randomly found one, and it showed up. So was that my problem? In older versions, I always used 100x100 icons and I guess they auto-resized? because they always displayed fine. Now 100x100 sized ones don't display, but the 50x50 one I found does. Or am I still missing something/doing something wrong?

comment:5 follow-up: Changed 8 years ago by MarkDoliner

  • Status changed from new to pending

This is basically a duplicate of #12874. I haven't been able to reproduce the problem, though. Would it be possible for you to attach the 100x100 icon that wasn't working?

Changed 8 years ago by magari

icon example

comment:6 Changed 8 years ago by magari

  • Status changed from pending to new

Attachment (jae4.jpg) added by ticket reporter.

comment:8 in reply to: ↑ 5 Changed 8 years ago by magari

Replying to MarkDoliner:

This is basically a duplicate of #12874. I haven't been able to reproduce the problem, though. Would it be possible for you to attach the 100x100 icon that wasn't working?

It's actually any 100x100 icon that I try. I've tried many of them, but I attached one. It's just like all of the others, so I figured it would be a good example.

comment:9 Changed 8 years ago by MarkDoliner

Lordy I don't know what's going on here. I can reproduce the problem with your provided icon (thanks!) as well as with a bunch of other test icons I have. I swear it used to work with these icons. It's almost like the server is rejecting the icons, but I'm not sure why. I'm wondering if it's strict about icons not having an alpha channel, or not being 32 bit, or being indexed instead of RGB or something. I dunno.

comment:10 Changed 8 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in aad06bbf6f9a5e7fd1f16c72be4af2060e8de4c3, which I just committed. This should get released in Pidgin 2.8.0 sometime in the next week. If you have a chance, please test once it's released and let me know if you still experience problems. Thanks!

comment:11 Changed 8 years ago by MarkDoliner

  • Milestone set to 2.8.0
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!