Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13329 closed defect (fixed)

does not build on rhel5 anymore

Reported by: waschk Owned by: darkrain42
Milestone: 2.7.11 Component: XMPP
Version: 2.7.10 Keywords:
Cc:

Description

pidgin 2.7.10 does not build on RHEL5 anymore:

make[5]: Entering directory `/usr/src/redhat/BUILD/pidgin-2.7.10/libpurple/protocols/jabber'

CC libjabber_la-bosh.lo

bosh.c:487: error: implicit declaration of function ‘g_warn_if_reached’

The macro g_warn_if_reached was added in glib 2.16, RHEL5 has 2.12.3.

I wanted to select version 2.7.10 but it was not in the list.

Change History (8)

comment:1 Changed 8 years ago by rekkanoryo

  • Component changed from libpurple to XMPP
  • Owner set to darkrain42

comment:2 Changed 8 years ago by darkrain42

  • Version changed from 2.7.9 to 2.7.10

Thanks for the report. The temporary fix would be to just delete it. Will fix for next release.

comment:3 follow-up: Changed 8 years ago by PCrichton

Same bug in Slackware 12.0 (glibc 2.5) Same bug in Slackware 12.2 (glibc 2.7)

comment:4 in reply to: ↑ 3 Changed 8 years ago by waschk

Replying to PCrichton: This is related to glib, not to glibc.

comment:5 Changed 8 years ago by PCrichton

Apologies, I should do my homework first. Mea culpa.

Slackware 12.0 with Dropline Gnome 2.20.3 = glib2 2.14.6 (way too old) Slackware 12.2 with Dropline Gnome 2.26.1 = glib2 2.20.5 (works fine)

comment:6 Changed 8 years ago by darkrain42

  • Milestone set to 2.7.11

comment:7 Changed 8 years ago by darkrain42

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!