Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13337 closed patch (fixed)

No AuthServ support

Reported by: tomos Owned by:
Milestone: 2.8.0 Component: libpurple
Version: 2.7.9 Keywords: authserv
Cc:

Description (last modified by tomos)

When connecting to an IRC channel which requires authentication with authserv (e.g. some channels on irc.gamesurge.net), an "unknown command" message is printed, effectively making these channels inaccessible. Fixing this requires the addition of the command to the array of commands in parse.c. I've attached a diff file but I'm not quite sure I did it properly. I downloaded the 2.7.9 source, made a copy of the file I was editing then generated a diff between that and the modified one. At any rate, it's a very simple addition so there shouldn't be a problem adding it.

Attachments (1)

diff (639 bytes) - added by tomos 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by tomos

comment:1 Changed 8 years ago by tomos

  • Description modified (diff)

comment:2 Changed 8 years ago by deryni

Ticket #13336 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by deryni

Ticket #13335 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by lelongt@…

  • Milestone set to 2.8.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 3c348145e821c215fdb8fd1ff1e68e0139457d21):
Add authserv support to IRC. Need a name to credit tomos with. Fixes #13337.

comment:5 Changed 8 years ago by rekkanoryo@…

(In cdf975015f8d160647bdb31d527b21445f446062):
ChangeLog tomos' patch. Refs #13337.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!