Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13386 closed defect (fixed)

ICQ / Oscar connects. Shows no one online and in the buddylist.

Reported by: stefanos Owned by: MarkDoliner
Milestone: 2.7.11 Component: ICQ
Version: 2.7.10 Keywords: buddylist show oscar icq
Cc:

Description (last modified by stefanos)

Trouble with pidgin 2.7.4 - 2.7.10 (win32, linux) with one of five icq numbers. In one icq number cannot see anything contact but in other icq numbers show all. I'am not alone see other german board http://forum.pidgin-im.de/showthread.php?tid=1229&page=1

I can connect to icq with all icq numbers with 2.7.3 on win32 and linux (debian lenny) ! My icq number is many years old from 2002 or 2000 but work in trillian, icq client or miranda very good in all versions and numbers.

See two pictures and debuglog, whats wrong on new pidgin version?

thanks.

Attachments (6)

pidgin2-7-4_2-7-10.png (28.6 KB) - added by stefanos 8 years ago.
pidgin 2.7.4 - 2.7.10 with on/offline buddy config
pidgin2-7-3.png (28.5 KB) - added by stefanos 8 years ago.
pidgin 2.7.3 with on/offline buddy config
icqnumberone.png (27.8 KB) - added by stefanos 8 years ago.
my trouble icq numbers connect on all pidgin versions
purple-debug2-7-4.log (13.9 KB) - added by stefanos 8 years ago.
pidgin purple debug log 2.7.4 - 2.7.10
purple-debug2-7-3.log (18.7 KB) - added by stefanos 8 years ago.
pidgin purple debug log 2.7.3
purple-debug_2-7-10.log (39.0 KB) - added by stefanos 8 years ago.
purple-debug2-7-10.log

Download all attachments as: .zip

Change History (23)

Changed 8 years ago by stefanos

pidgin 2.7.4 - 2.7.10 with on/offline buddy config

Changed 8 years ago by stefanos

pidgin 2.7.3 with on/offline buddy config

Changed 8 years ago by stefanos

my trouble icq numbers connect on all pidgin versions

Changed 8 years ago by stefanos

pidgin purple debug log 2.7.4 - 2.7.10

comment:1 Changed 8 years ago by stefanos

  • Keywords oscar icq added
  • Summary changed from CQ connects. Shows no one online and in the buddylist. to ICQ / Oscar connects. Shows no one online and in the buddylist.

comment:2 Changed 8 years ago by stefanos

  • Description modified (diff)

Changed 8 years ago by stefanos

pidgin purple debug log 2.7.3

comment:3 Changed 8 years ago by deryni

  • Keywords changed from buddylist, show, oscar, icq to buddylist show oscar icq

comment:4 Changed 8 years ago by dustin

Can you do a debug log on 2.7.10? There should be a sequence of lines like:

(14:24:27) oscar: buddy list loaded
(14:24:28) oscar: ssi rights: max type 0x0000=3000, max type 0x0001=100, max type 0x0002=1000, [...]
(14:24:28) oscar: Reading items from tlvlist for account xxxxxxxxx:    <---
     gid=0x0000, bid=0x0000, list_type=0x0001 [Group], name=(null).
     gid=0x0000, bid=0x0001, list_type=0x0004 [PDInfo], name=(null).
     gid=0x0000, bid=0x0002, list_type=0x0005 [PresencePrefs], name=(null).
     gid=0x0000, bid=0x0003, list_type=0x0014 [Buddy Icon], name=1.
     [..]
     gid=0x0001, bid=0x0000, list_type=0x0001 [Group], name=Buddys.
     gid=0x0001, bid=0x0001, list_type=0x0000 [Buddy], name=yyyyyyyyy.
     [etc.]
(14:24:28) oscar: ssi: syncing local list and server list
(14:24:28) oscar: ssi: activating server-stored buddy list
[..]

Might be helpful to see if the buddy list is actually read in (entries with gid != 0x0000).

Changed 8 years ago by stefanos

purple-debug2-7-10.log

comment:5 Changed 8 years ago by stefanos

sure, see the purple-debug2-7-10.log in the attachments

comment:6 Changed 8 years ago by dustin

So the blist is read from the server and also the local list is updated to it, so far so good.

Just to rule out the possibility: Are you sure there aren't any outdated plugins activated?

Is the buddy list displayed on other clients with libpurple >= 2.7.4, e.g. finch or Adium X? (For finch, check if you're using the right binary with finch --version).

comment:7 Changed 8 years ago by stefanos

blist.xml is not updated but yes the blist is read from server. It is the edition from pidgin.im without any active plugins on all versions!

I checked with finch 2.7.9 (on debian6 squeeze) and i cannot see my buddylist.

comment:8 Changed 8 years ago by stefanos

i think for adium (mac) help this bugreport http://trac.adium.im/ticket/14901

comment:9 Changed 8 years ago by einue

I have the same problem with my very old icq number. It still works in 2.7.3 but not in 2.7.10.

comment:10 follow-up: Changed 8 years ago by MarkDoliner

stefanos: Do you see people listed in the "Allow only the users below" and "Block only the users below" lists under Tools->Privacy?

Have you tried moving your existing blist.xml file out of the way to see if that helps? You would want to:

  1. Quit Pidgin
  2. Rename blist.xml to blist.xml.original (information on where to find this file is at the top of http://developer.pidgin.im/wiki/ConfigurationFiles)
  3. Start Pidgin

If that doesn't work you'll probably want to quit Pidgin then rename blist.xml.original back to blist.xml. Otherwise you might lose buddy aliases for protocols that don't support storing aliases server-side, and possibly other not-usually-critical information.

comment:11 in reply to: ↑ 10 Changed 8 years ago by stefanos

no, i see not any people in both lists. After delete blist.xml is not better with my icq number.

comment:12 Changed 8 years ago by MarkDoliner

stefanos: Thank you for checking, and thank you for all the information you have provided so far.

This is quite an interesting bug. It does appear that the oscar protocol plugin receives your buddy list from the ICQ servers. And it does seem like it's parsing it. It's very strange that your buddies don't show up. I'll look around a little more and see if I can figure anything out.

For what it's worth I believe this is happening to a fair number of people--not just yourself.

comment:13 Changed 8 years ago by MarkDoliner

Ok, I think I might have found the problem. stefanos: It would be great if you could test my change and confirm if it fixes it. You don't compile your own Pidgin from our monotone repository, do you?

If not, would you want to log in to https://www.meebo.com/messenger with your bad ICQ account and make sure that your buddy list does not load? Once you've done that I can apply the bug fix to Meebo's code (I work there) and you can try logging in again and check if it works.

comment:14 Changed 8 years ago by markdoliner@…

  • Milestone set to 2.7.11
  • Resolution set to fixed
  • Status changed from new to closed

(In a657534f694305a613db4946ca8ea9ab4c8f1c1d):
OOH! I think I found the cause of a bug! I changed this function in revision eadc83c534fbbc673a6876ddb1e0bdac8428c07b to try to make it cleaner. When I did that, I added a break here when I should have added a continue. The result is that if we encounter a non-utf8 name for an item in your server side buddy list then we bail out earlier and don't add any server stored buddies to your local list. That's bad. I think this caused a lot of people to not see their complete buddy list. This probably affected ICQ users a lot more than AIM users, because ICQ users tend to use more 3rd party IM clients, and 3rd party IM clients sometimes put non-utf8 text in the name field of these items when they shouldn't.

Hopefully fixes #13386

comment:15 Changed 8 years ago by stefanos

yes your continue patch is very good. I see my contacts. Thanks!

comment:16 Changed 8 years ago by MarkDoliner

Great! Thank you!

comment:17 Changed 8 years ago by MarkDoliner

Ticket #13062 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!