Opened 8 years ago

Closed 2 years ago

#13408 closed defect (out of date)

Pidgin (or msn) drop messages silently

Reported by: Waxhead Owned by: QuLogic
Milestone: Component: MSN
Version: 2.7.9 Keywords: msn drop message reject discard
Cc:

Description

Since pidgin 2.7.6? (i think) and untill now 2.7.9 MSN seems to sliently drop messages from time to time. This have happened with several of my buddies in both directions. Some of them use pidgin and others use the (pesky) msn client from ms.

I can't reproduce this in such a way that it happens all the time but it *seems* that multi line messages, long messages and/or messages who have had links in them trigger this problem either directly or indirectly (e.g. later messages gets dropped).

Is there something I can do to try to pinpoint the problem?

Change History (8)

comment:2 in reply to: ↑ 1 Changed 8 years ago by Waxhead

Replying to chemistrydioxide:

Microsoft uses to censor messages.

http://developer.pidgin.im/wiki/Protocol%20Specific%20Questions#Whydosomeofmymessagesresultinanerror

Thanks but this is (most likely not always) the reason messages get dropped.

comment:3 Changed 8 years ago by blackwolf

I created an account just so I could comment on this. I am having the same problem. It's really a big problem for me, because I'm trying to use Pidgin at work. When a co-worker sends me a message and I don't get it, that's a problem. I really don't want to go back to the crummy MS client, but I may have to if this doesn't get resolved.

Also, I don't think the problem has to do with censoring because often times simple messages that don't have links or "questionable" content are getting dropped. As the OP stated, multi-line messages seem to be more likely affected, but I've also had short single-line messages be dropped.

comment:4 follow-up: Changed 8 years ago by blackwolf

Another data point that may help with this issue: I have the "Use HTTP Method" checked on the Advanced tab for the account. I turned this on because I was having trouble connecting to MSN over VPN (which I need in order to work from home), and checking that box got over that problem.

I don't know if this is helpful or if the OP also had this setting on. But just in case, now you know.

comment:5 in reply to: ↑ 4 Changed 8 years ago by Waxhead

Replying to blackwolf:

Another data point that may help with this issue: I have the "Use HTTP Method" checked on the Advanced tab for the account. I turned this on because I was having trouble connecting to MSN over VPN (which I need in order to work from home), and checking that box got over that problem.

I don't know if this is helpful or if the OP also had this setting on. But just in case, now you know.

I don't use the 'HTTP method'. I am also still unable to reproduce the problem but I still think links, and exotic characters (like æ,ø,å) and perhaps long messages *sometimes* either trigger this problem directly or indirectly e.g. I after 10-15 more messages it drop messages without any notification what so ever.

comment:6 Changed 5 years ago by rekkanoryo

  • Owner changed from rekkanoryo to EionRobb

comment:7 Changed 3 years ago by dx

  • Component changed from unclassified to MSN
  • Owner changed from EionRobb to QuLogic

comment:8 Changed 2 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all MSN tickets, since it has been removed in pidgin 2.12.0 after being broken for a couple of years (see http://ismsndeadyet.com/). The skypeweb plugin can be used as an alternative (yes, it supports MSN logins too)

If this issue is still present in any other protocols supported by pidgin, please leave a comment and we will reopen it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!