Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#13419 closed defect

Invisible status breaks IRC login

Reported by: zauberexonar Owned by: elb
Milestone: Component: IRC
Version: 2.7.10 Keywords:
Cc:

Description

For the past month or so, I have been keeping myself invisible in pidgin. And, during that time, IRC was unusable, forcing me to use empathy for IRC, and it has inferior support to IRC compared to pidgin.

Just today, I stopped using the invisible status, and IRC suddenly began working again. However, based on my observations the invisible status only breaks IRC when you sign on with invisible as your default status. So, it only appears to be affecting logins/authentication.

Change History (4)

comment:1 Changed 8 years ago by QuLogic

  • Status changed from new to pending

This is working as intended. The IRC protocol has no concept of invisible and thus your status does not change at all (ergo, starting Pidgin will mean IRC is offline, and so it will stay offline).

If you want IRC to go to a specific status, you should create a custom status setting everything to invisible and IRC to Available.

comment:2 Changed 8 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:3 Changed 7 years ago by chemistrydioxide

I think that this behavior is not intuitive. I think there should be two "invisible" statuses. One which makes the user visible on accounts that don't support invisibility and another one which disconnects such accounts.

comment:4 Changed 7 years ago by deryni

It is unfortunately unintuitive but that solution isn't a valid solution either (nor is it particularly simpler to understand or explain).

The issue isn't as simple as online/offline. The issue is that when a global status is selected and an account that doesn't support that status is enabled libpurple cannot switch that account to that status and currently simply leaves the previously set status in place (whatever that status was). The problem with fixing this is that there really isn't a good way to know what status we should use instead (if any). Without some explict complicated user configuration and/or a much more detailed status equivalence system (which boils down to complicated user configuration but in a more general form).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!