Opened 12 years ago

Closed 10 years ago

Last modified 3 years ago

#1345 closed enhancement (fixed)

XMMP: Set priority

Reported by: tulio Owned by: deryni
Milestone: Plugin Suggested Component: XMPP
Version: 2.0.1 Keywords:
Cc: darkrain42, kenyon, greve, Michael83, Natanji, vnicolici, daryltucker, jjwieland

Description

The XMMP protocol has no option to set the priority. It is important to have multiple IM run with the same login on different desktops. Please add a feature.

Change History (40)

comment:1 Changed 12 years ago by lschiere

  • Milestone set to 2.1.0
  • Owner set to nwalp
  • priority changed from minor to major
  • Type changed from defect to enhancement

comment:2 Changed 12 years ago by misc

This could be done based on the current status, like gossip and gajim does. Ie, set the priority on 50 when user is present, and less when he is away, so the messages are routed like people believe they will, ie to the most active ressource, ie the one with highest priority.

comment:3 Changed 12 years ago by tulio

Great. Thank you very much for the fast enhancement in version 2.1.

comment:4 Changed 12 years ago by schoen

The user should be able to set priorities both for »available« status and one for away, extended away, busy etc. Or, at least, the default priority should be higher than ‘1’.

An idea would be to include a dialog to set priority when setting up a new away message.

comment:5 Changed 12 years ago by lschiere

  • Milestone changed from 2.1.1 to 2.2.0

I believe this will require new API, so it cannot be a x.y.* release.

comment:6 Changed 12 years ago by seanegan

  • Component changed from pidgin (gtk) to XMPP

comment:7 Changed 11 years ago by dpc

Oh. Just please change the defaults for now.

Default '1' isuseless. Good default would be 5 - 15 IMO. 1 == "last resource you'd like to talk with'.

comment:8 Changed 11 years ago by deryni

What other clients are you using which are in less available modes that are setting higher priorities? Or more to the point what about pidgin setting a priority of 1 for available is causing you problems?

comment:9 Changed 11 years ago by dfalk

Google Talk. It sets the priority at 24 when marked as Away. This makes me look like I'm away unless I remember to sign out at work. It's annoying to look like you're away all weekend.

comment:10 Changed 11 years ago by deryni

Adding a bit of information from ticket #4500, apparently Adium has a single per-account priority setting for 'available' and one for 'away'. The submitter filed to request at least that much functionality.

comment:11 Changed 11 years ago by CrazyTerabyte

Slightly off-topic, but... This chapter from "Programming Jabber" book says the priority number must be positive, and not zero.

Anyway, I also want to be able to set my own priority.

comment:12 follow-up: Changed 11 years ago by deryni

That book is old and out of date, both the current XMPP rfc (http://www.xmpp.org/rfcs/rfc3921.html) and the bis draft of the rfc (http://www.xmpp.org/internet-drafts/draft-saintandre-rfc3921bis-04.html#presence-priority) indicate a range of -128 to 127.

I still maintain that doing a poor attempt at priority setting isn't worth it and that a correct implementation is complicated, and that furthermore clients that use 'high' priorities for unavailable statuses should probably be changed. I would be more than happy for someone to take a poll of the default priorities for the available and away statuses among the majority of the XMPP clients that exist and report back, if there is a clear pattern then I would see no reason not to change pidgin to match that.

comment:13 in reply to: ↑ 12 Changed 11 years ago by CrazyTerabyte

Gmail uses 24 for Online and DND statuses, and 0 for away. GTalk also uses 24 for Online status, I guess it does not change the priority for away. (I'm looking at priorities of friends from my contact list)

Psi has a configurable priority and it doesn't change the priority when away. The same applies to Kopete. IIRC, the default priorities for Psi and Kopete are 5 and 7, or some other value near these.

I have an away friend right now using Miranda IM, and the priority is 0. I don't know the Mirada IM priority when online.

Also, I don't remember the default priority for Bombus J2ME mobile client.

Anyway, I still think the user must be able to configure the priority(ies) in pidgin, but of course pidgin should have a sensible default.

comment:14 follow-up: Changed 11 years ago by liviopl

This is very useful feature. +1

comment:15 Changed 11 years ago by liviopl

How do I Cc me here?

comment:16 Changed 11 years ago by deryni

  • Owner changed from nwalp to deryni

liviopl: Adding a comment to a ticket adds you to the CC list for that ticket's emails.

comment:17 Changed 11 years ago by liotier

This is an important feature for people with multiple workstations and mobile devices. Like a few people around me, I use Psi mostly because Pidgin lacks this capability.

comment:18 Changed 11 years ago by saddie

I just switched to Pidgin from an older IM application and it has everything I need *except* an ability to set XMMP priority. Since I log into my accounts from three possible locations, the ability to control where messages go to is very much needed.

comment:19 Changed 11 years ago by eMxyzptlk

Just adding myself to the CC list.

comment:20 in reply to: ↑ 14 Changed 11 years ago by nagelp

This is very useful feature. +1

I second that. Adding myself to the CC list.

comment:21 Changed 11 years ago by zerwas

+1. (reply to be on CC list)

comment:22 Changed 10 years ago by thenktor

+1

I need this feature for my netbook. For me it would be enough to set a priority in the settings.

comment:23 Changed 10 years ago by darkrain42

Given that Google Talk (in some/most of its incarnations) uses a default priority of 24, it would probably make sense to use a priority of 24 for Google Talk accounts (at least for Available/DnD).

I'd love to see the Adium interface make its way over here (two per-account settings allowing users to specify the available/chatty and away/dnd/xa priorities). The defaults could be what Pidgin does currently (since, for the most part, it doesn't hurt anything) but would let crazy people who need/want to to prioritize their resources likely as-needed.

comment:24 Changed 10 years ago by deryni

As I've said before, my personal opinion is that if we are going to give people a way to do this we need to give them a real interface for it and not some half-hearted attempt. In my opinion, the Adium interface is such an attempt. I will likely not stop someone from accepting a patch that adds it but I will not work on it. I'd much sooner see a plugin which allowed for setting and saving priorities for each status for each account, and ideally even integrated into the new status dialog to let the user set priorities per-saved-status (this may or may not be possible at the moment).

comment:25 Changed 10 years ago by kenyon

+cc

comment:26 Changed 10 years ago by vitb

+<many> to this feature.

What about specifying such priorities numbers in xmpp account settings? these values are not changed often normally, just one set usually fits users needs, depending on what clients one is using and how it is desired to prioritize available/away/etc conditions among them.

comment:27 Changed 10 years ago by greve

+1

I would like to add my voice to the chorus of people asking for this enhancement.

It would be great to be able to set the priority, e.g. as part of the status messages.

comment:28 Changed 10 years ago by ronny

+1 :-)

comment:29 Changed 10 years ago by darkrain42

A dirty hack plugin that allows you to configure per-account priorities for available [available and chat] and away [away, dnd, and xa] will be in the next release of the Purple Plugin Pack (see ppp:c26f0821a99d6038e80e7b7bc9400056a41b1ee4).

My plans include the ability to adjust the priority for a specific saved status from the status dialogs (This won't happen before Pidgin 2.6.0, though, since it will require new APIs) and a decay function (based on time idle).

comment:30 Changed 10 years ago by rekkanoryo

  • Milestone set to Plugin Suggested
  • Resolution set to fixed
  • Status changed from new to closed

This is fixed by the plugin darkrain42 wrote.

comment:31 Changed 8 years ago by Robby

Ticket #13740 has been marked as a duplicate of this ticket.

comment:32 Changed 6 years ago by Natanji

Well, since https://www.guifications.org/projects/purple-plugin-pack is no longer reachable (the whole domain isn't), is this maybe something we could finally see in pidgin natively - without the need of a huge external plugin pack? ;)

comment:33 Changed 6 years ago by rekkanoryo

The Purple Plugin Pack is available here. And you do not need the entire plugin pack. You can install and activate only the plugins you want. There are currently no plans to include this feature in Pidgin or libpurple themselves; that could change in the future, but I don't see it happening anytime soon.

comment:34 Changed 6 years ago by vnicolici

IMO this is a core feature for XMPP, it should be included in pidgin / libpurple.

comment:35 Changed 5 years ago by rubo77

please re-open this ticket.

It is more and more important these days, since chat on mobilephones works well now, for example with ChatSecure?

comment:36 Changed 5 years ago by sonnyka

Strong vote for re-opening this ticket and making priority a core feature of Pidgin/libpurple.

  1. The current add-on implementation is broken and it is unclear if it will be fixed. (see [1]). Consequence: No priority management is possible atm.
  1. Other projects relying on libpurple have the same problem, e.g. Instantbird from Mozilla (see [2]). Consequence: No priority management will ever be possible w/o adding prio management to core.
  1. Multi-client environments have become increasingly popular due to smart phones. They can not be properly used together with Pidgin, as messages always end-up on the wrong device.

[1] https://bitbucket.org/rekkanoryo/purple-plugin-pack/issue/7/plugin-xmppriority-not-working-in-pidgin#comment-8355943 [2] https://groups.google.com/forum/#!msg/mozilla.support.instantbird/NIRmA8XYeoM/FMdjKQ0AjUAJ

comment:37 Changed 5 years ago by rubin110

Debian Sid amd64 pidgin 2.10.9-1 and pidgin-extprefs 0.7-2 from the Debian repo

I have accounts through Google Apps for Domains and jabber.ccc.de, I'm also running more clients then I should.

After a friend on Twitter today asked what behavior does Google follow in determining which client messages go to, I wanted to take a quick screenshot of my "Buddy Information" windows for each account to show him the resource priorities I had set through the XMPP Priority plugin.

As it turns out whatever is being reported back through that information window seems to be incorrect or quoting something else. In the preferences I've got the available priority for Pidgin set to 25, but the information window display 1 for each account. I do remember this window returning the correct values.

Am I missing something?

Also another +1 to reopening this issue. Pidgin should have this option available by default and not through a plugin.

Last edited 5 years ago by rubin110 (previous) (diff)

comment:38 Changed 5 years ago by daryltucker

I am being forced to switch from Pidgin (after having used it for over ten years) because the XMPP settings are lacking this feature, as well as the fact that Pidgin doesn't support many newer cryptographic ciphers, such as the following:

ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256

Subscribing to [hopefully] be notified if this gets built into Pidgin.

Thanks.

comment:39 Changed 4 years ago by jjwieland

I found that if I set the priority, and then exited out of pidgin and restarted it, that it would take effect. It doesn't work if I change it, and the just log out Google Talk and back in. I had to restart Pidgin. This is with version 2.10.11, Purple Plugin Pack 2.7.0, compiled and running on SPARC Solaris. It's clumsy, but it seems to work.

comment:40 Changed 3 years ago by alexo

Please revisit the bug

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!