Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13500 closed defect (fixed)

Cannot add buddies on AIM with periods in their names

Reported by: e_ Owned by: MarkDoliner
Milestone: 2.10.2 Component: AIM
Version: 2.7.11 Keywords: . period add aim oscar ssi
Cc:

Description (last modified by e_)

When trying to add someone via Pidgin: Unable to add the buddy a.b.c.d because the username is invalid. Usernames must be a valid email address, or start with a letter and contain only letters, numbers and spaces, or contain only numbers.

Adding it to the XML gives this message in debug: oscar: ssi: removing buddy a.b.c.d from local list

(username changed for privacy reasons but follows same format)

Change History (13)

comment:1 Changed 7 years ago by e_

  • Description modified (diff)

comment:2 Changed 7 years ago by MarkDoliner

When I try to register a username containing a period at https://new.aol.com/productsweb/Controller.jpf?promocode=825028&ncid=txtlnkuswebr00000002 it shows me the message "Your username may not contain characters such as @, !, * or $."

Are you sure the name you're adding is valid and correct...?

It's not an email address, is it?

comment:3 Changed 7 years ago by e_

It's not an email. It's valid and I can send and receive messages. I have no idea how the person using it registered it.

comment:4 Changed 7 years ago by chemistrydioxide

Maybe AOL no longer allows this for new users but used to do so?

comment:5 Changed 7 years ago by chemistrydioxide

Maybe AOL used to allow this in former times but no longer does.

comment:6 Changed 7 years ago by ketsundere

AOL currently allows this. I have a friend who just registered a name similar to a.b.c.d within the past few days, and I can't add him to my buddy list because of this error.

comment:7 Changed 7 years ago by MarkDoliner

Ticket #14855 has been marked as a duplicate of this ticket.

comment:8 Changed 7 years ago by Robby

Also reported for Adium: #a15500.

comment:9 Changed 7 years ago by MarkDoliner

Ticket #14847 has been marked as a duplicate of this ticket.

comment:10 Changed 7 years ago by MarkDoliner

I checked in a fix for this. As a workaround, I believe you can use "username@…" and things should mostly work.

comment:11 Changed 7 years ago by markdoliner@…

  • Milestone set to 3.0.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 13d6e924c9257b20e21050646cab88043bdb2e15):
Allow signing on with usernames containing periods and underscores. Allow adding buddies containing periods and underscores.

Fixes #13500.

comment:12 Changed 7 years ago by Robby

Ticket #14881 has been marked as a duplicate of this ticket.

comment:13 Changed 7 years ago by markdoliner@…

  • Milestone changed from 3.0.0 to 2.10.2

(In fdd2e607e8dbe0cbd6584455a9e71b0659f2c29f):
* Plucked 13d6e924c9257b20e21050646cab88043bdb2e15 (markdoliner@…): Allow signing on with usernames containing periods and underscores. Allow adding buddies containing periods and underscores.

Fixes #13500.

* Plucked 9bc480e430c705484b95bc77407b0956800cdab4 (grim@…): Fix mark's commit and allow aim accounts to work again

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!