Opened 7 years ago

Closed 6 years ago

#13549 closed defect (duplicate)

cannot copy and paste Chinese text from google chrome

Reported by: slacka Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.7.11 Keywords: chrome Chinese
Cc:

Description

What steps will reproduce the problem?

  1. In Google Chrome go to http://translate.google.com/#en|zh-CN|
  2. Write some sample English text.
  3. Translate text to Chinese.
  4. Highlight text
  5. Copy and paste text into Pidgin chat window.

What is the expected result? Expect to see same text as was in google translate window.

What happens instead? Text will appear as block symbols and cannot be read by sender or receiver.

OS: Bug reproduced under Win7 and Win XP

Attachments (1)

PidginChinese.PNG (36.3 KB) - added by slacka 7 years ago.
Copy-Paste Chrome Bug

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by slacka

Copy-Paste Chrome Bug

comment:1 Changed 7 years ago by QuLogic

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from rekkanoryo to datallah

comment:2 Changed 6 years ago by slacka

I tested in both XP and win7 with Pidgin 2.10.1 (libpurple 2.10.1) and google Chrome 18.0.983.0 canary build. In both cases the bug was easily reproducible and has not been fixed.

comment:3 Changed 6 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #604.
It is actually correctly copying and pasting the text - the reason that it shows up as the squares with numbers in them is because the font being used to render the text input can't render the Chinese glyphs.

The ticket I'm marking this as a duplicate of has more information about the font situation.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!