Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#1355 closed patch (wontfix)

Maximized Buddy-List Window

Reported by: Menedas Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.0.1 Keywords: window size
Cc:

Description

How to reproduce the bug:

  1. Open Pidgin Buddy-List window by double click on the tray icon.
  2. Maximize the opened Pidgin Buddy-List window.
  3. Normalize the window again.
  4. Minimize the window to tray.
  5. Open Pidgin by double click on the tray icon.

Now the Pidgin Buddy-List window opens maximized and can't normalize again. It can only been solved by shrinking the window manually.

Attachments (1)

gtkblist-win32-configure-cb-hack.patch (855 bytes) - added by charkins 11 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by mitzman

I remember that I saw this in 2b5 I think. It was fixed for a while but definitely shows back up in 2.0.1. Was working perfectly in 2.0.0 final.

comment:2 Changed 11 years ago by Menedas

I've seen this bug in 1.5 and also in 2.0.0.

comment:3 Changed 11 years ago by lschiere

  • Milestone set to 2.1.1
  • Owner changed from datallah to charkins

comment:4 Changed 11 years ago by charkins

  • Status changed from new to assigned

comment:5 Changed 11 years ago by charkins

  • Owner changed from charkins to datallah
  • Status changed from assigned to new

I'm passing this off to datallah to get his input.

The work around in gtk_blist_configure_cb for gtk bug #169811 doesn't work consistently. Sometimes gdk_get_window_state() is telling us the window is not maximized during maximization. Other times it tells us the window is maximized during a restore.

Since this doesn't seem to be reliable, we could make the assumption that if the buddy list is >90% of the width and height, that the window is maximized (and the size/position is not stored). This would be a horrible hack, but I can't think of another easy way to fix this.

Patch is attached if you want to try it out. Feel free to apply if you think this is the best way to fix this, or pass it back to me to apply if you don't want your name attached to such an ugly hack. :-)

Changed 11 years ago by charkins

comment:6 Changed 10 years ago by rlaager

  • Type changed from defect to patch

comment:7 Changed 10 years ago by rekkanoryo

Do we want to apply this patch or mark this as not our bug?

comment:8 Changed 10 years ago by rekkanoryo

  • Resolution set to wontfix
  • Status changed from new to closed

Considering no one has bothered to comment on this ticket in 5 weeks after it sat idle for 7 months, I think it's safe to say that this patch isn't going to be accepted.

comment:9 Changed 10 years ago by Menedas

Current status with 2.53 is, a maximized Buddylist minimized to tray will be opened as not maximized window which solve the bad behaviour. Thats ok to me. But if someone likes maximized buddy lists and uses the Tray then he will have a problem, always have to maximize the window manually again.

comment:10 Changed 7 years ago by liquen

I'm experiencing this issue right now with Pidgin 2.8.0 in Linux. Exactly as OP described 4 years ago. Interestingly, this only happens with xfwm4 (I tested with metacity and everything is fine).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!