Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13774 closed defect (fixed)

crash in Voice/Video Configuration

Reported by: ari Owned by: Maiku
Milestone: 2.8.0 Component: Voice and Video
Version: 2.7.11 Keywords:
Cc:

Description

From http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=611678#44

in the upgraded version this bug presists on my computer, but if i rename $HOME/.purple and lauch pidgin (creating a new .purple/ directory) Voice/Video? setting opens normally allowing me to configure which device to use.

Backtrace attached.

Attachments (2)

pidgin2.7.11-full_bt.txt (7.8 KB) - added by ari 8 years ago.
prefs.xml (22.3 KB) - added by ari 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by ari

comment:1 Changed 8 years ago by QuLogic

  • Component changed from unclassified to Voice and Video
  • Status changed from new to pending

Please attach the broken ~/.purple/prefs.xml.

Changed 8 years ago by ari

comment:2 Changed 8 years ago by ari

  • Status changed from pending to new

Attachment (prefs.xml) added by ticket reporter.

comment:3 Changed 8 years ago by QuLogic

  • Owner changed from rekkanoryo to Maiku

comment:4 Changed 8 years ago by QuLogic

  • Status changed from new to pending

I am unable to reproduce with the supplied config, although there is a bit of a delay when opening the plugin config with ALSA set as audio source. It appears that you have a problem with the gstreamer ALSA plugin (alsasrc). Can you reproduce the crash in the clean config by setting the audio source to ALSA?

comment:5 Changed 8 years ago by QuLogic

Actually, perhaps the problem is you do not have the alsasrc plugin at all? You can test with gst-inspect alsasrc.

comment:6 Changed 8 years ago by ari

  • Status changed from pending to new

alsasrc is not installed. If it is installed, the crash goes away.

comment:7 Changed 8 years ago by pat@…

  • Milestone set to 2.8.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 49f43a7a76fe68d77402d22dcf9dfc19e5989467):
Fix another vvconfig crash. Fixes #13290, #13774.

comment:8 Changed 8 years ago by QuLogic

Ticket #13107 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!