Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14248 closed patch (fixed)

Update libgadu to 1.11.0

Reported by: tomkiewicz Owned by:
Milestone: 2.8.0 Component: Gadu-Gadu
Version: 2.7.11 Keywords: libgadu
Cc:

Description (last modified by tomkiewicz)

New libgadu was released a week ago.

Among others, it introduces some features, that will help us dealing with connection errors (see 1102, 1104, 1105 on svn). Also, it can enforce SSL connections (see 1093) - that means, if SSL connection will be unsuccessful, it won't fall back to plain-text mode.

I have reduced differences with upstream version of libgadu to minimum, so following updates will be easier. Also, I managed to fix all warnings when building and some bugs that was present in our fork of libgadu.

This version was tested under Linux 32bit and Windows 7 32bit (cywgin).

The libgadu-purple-1.10.1.diff and libgadu-purple-1.11.0.diff files shows differences between upstream libgadu and our fork. These are NOT patches. pidgin-gg-libgadu-1.11.0.patch should be used as a patch.

Attachments (3)

pidgin-gg-libgadu-1.11.0.patch (100.4 KB) - added by tomkiewicz 8 years ago.
Patch updating (both internal and external) libgadu to 1.11.0
libgadu-purple-1.10.1.diff (42.1 KB) - added by tomkiewicz 8 years ago.
Summary of differences between upstream and our fork of 1.10.1
libgadu-purple-1.11.0.diff (19.8 KB) - added by tomkiewicz 8 years ago.
Summary of differences between upstream and our fork of 1.11.0

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by tomkiewicz

Patch updating (both internal and external) libgadu to 1.11.0

Changed 8 years ago by tomkiewicz

Summary of differences between upstream and our fork of 1.10.1

Changed 8 years ago by tomkiewicz

Summary of differences between upstream and our fork of 1.11.0

comment:1 Changed 8 years ago by tomkiewicz

  • Description modified (diff)

comment:2 Changed 8 years ago by tomkiewicz

  • Type changed from defect to patch

comment:3 Changed 8 years ago by Robby

  • Milestone set to 2.8.0
  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 8 years ago by tomkiewicz

There is a problem: two new files (deflate.c and deflate.h) were not included in commit (see patch).

Also, the entry "Require libgadu 1.10.1..." should be updated.

comment:5 Changed 8 years ago by darkrain42

  • Resolution fixed deleted
  • Status changed from closed to new

comment:6 Changed 8 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 8 years ago by darkrain42

Oops, no, that's good.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!