Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14302 closed defect (fixed)

MSN offline messages are not sent, there is no notification in the chat window

Reported by: gd Owned by: QuLogic
Milestone: 2.10.2 Component: MSN
Version: 2.8.0 Keywords:
Cc:

Description (last modified by gd)

I've noticed that ows.messenger.msn.com is being sent to 127.0.0.1 this is preventing the offline messages from being delivered. The debug windows shows

(20:31:57) dns: Got response for 'ows.messenger.msn.com'
(20:31:57) dnsquery: IP resolved for ows.messenger.msn.com
(20:31:57) proxy: Attempting connection to 127.0.0.1
(20:31:57) proxy: Connecting to ows.messenger.msn.com:443 with no proxy
(20:31:57) proxy: Connection in progress
(20:31:57) proxy: Connecting to ows.messenger.msn.com:443.
(20:31:57) proxy: Error connecting to ows.messenger.msn.com:443 (Conexión rehusada).
(20:31:57) proxy: Connection attempt failed: Conexión rehusada
(20:31:57) msn: cannot send OIM: this is an OIM

But the chat window shows no error.

I know this is not a problem of pidgin, none the less I think the user should be informed that the message did not get through in the chat window, and not only in the debug log.

Change History (18)

comment:1 Changed 8 years ago by gd

  • Description modified (diff)

comment:2 Changed 8 years ago by gd

  • Description modified (diff)

comment:3 Changed 8 years ago by gd

This is still present in 2.9.0
are messages to invisible buddies working?
I cannot send them from Pidgin, but the official client allows it

comment:4 Changed 8 years ago by QuLogic

  • Keywords offline instant message not delivered error notification removed
  • Status changed from new to pending

Clearly this is some kind of local network problem. ows.messenger.msn.com shouldn't be resolving to 127.0.0.1. You should figure out why that's happening for you.

comment:5 Changed 8 years ago by gd

  • Status changed from pending to new

doing "dig @8.8.8.8 ows.messenger.msn.com" resolves to ows.msnmessenger.msn.com.akadns.net and finally to 127.0.0.1
same result using opendns
would you mind giving me the ip you resolved?


either way I think the user should be notified when a message could not be delivered

Thanks!

comment:6 Changed 8 years ago by Tails

I'm getting the same thing here, so this is definitely not a local problem:

tails@kubuntu ~/ % nslookup 'ows.messenger.msn.com'
Server:         192.168.1.1
Address:        192.168.1.1#53

Non-authoritative answer:
ows.messenger.msn.com   canonical name = ows.msnmessenger.msn.com.akadns.net.
Name:   ows.msnmessenger.msn.com.akadns.net
Address: 127.0.0.1

This problem seems to affect most unofficial clients, unfortunately. As gd says, until a proper way to fix the issue is found, I think there should be a way to inform the user that the message couldn't be delivered. I'm sure a lot of people are trying to send offline messages and think that everything went smoothly, while in fact the message isn't even sent.

comment:7 Changed 8 years ago by Elyk

I have been getting the same thing as well as several of my buddies. Trying to send an offline message:

(19:57:00) msn: prepare to send offline Message
(19:57:00) msn: Sending OIM: test
(19:57:00) msn: No lock key challenge, waiting for SOAP Fault and Resend
(19:57:00) msn: Encoding OIM Message...
(19:57:00) msn: Encoded base64 body:{dGVzdA==}
(19:57:00) dnsquery: Performing DNS lookup for ows.messenger.msn.com
(19:57:00) dnsquery: Error resolving ows.messenger.msn.com: 11004
(19:57:00) proxy: Connection attempt failed: Error resolving ows.messenger.msn.com: 11004
(19:57:00) msn: cannot send OIM: test

A friend trying to send me an offline message:

(05:34:55) dnsquery: Performing DNS lookup for ows.messenger.msn.com
(05:34:55) dnsquery: Error resolving ows.messenger.msn.com: 11001
(05:34:55) proxy: Connection attempt failed: Error resolving ows.messenger.msn.com: 11001(05:34:55) dnsquery: Performing DNS lookup for ows.messenger.msn.com
(05:34:55) dnsquery: Error resolving ows.messenger.msn.com: 11001
(05:34:55) proxy: Connection attempt failed: Error resolving ows.messenger.msn.com: 11001

Invisible messages have no issue.

Attempting to ping ows.messenger.msn.com also fails so it is possible that msn has changed servers.

comment:8 Changed 8 years ago by Ryu84

Yes,

i have also this issue, hoping that the new releases will fix this

comment:9 Changed 8 years ago by jroberts

The attention this bug has received seems kind of disappointing, IMO. Messages aren't being delivered, and users are given no indication there's been a failure unless they happen to have the debug window open. Most probably don't even know their messages are being eaten.

This is profoundly broken.

comment:10 Changed 8 years ago by Harry_The_Bustard

Here is the view from Adium 1.4.2...

18:31:17: (Libpurple: msn) send IM {Test} to {redacted.party}@passport.com
18:31:17: (Libpurple: msn) prepare to send offline Message
18:31:17: (Libpurple: msn) Sending OIM: Test
18:31:17: (Libpurple: msn) No lock key challenge, waiting for SOAP Fault and Resend
18:31:17: (Libpurple: msn) Encoding OIM Message...
18:31:17: (Libpurple: msn) Encoded base64 body:{VGVzdA==}
18:31:17: (Libpurple: dns) DNS query for 'ows.messenger.msn.com' queued
18:31:17: -[AdiumPurpleDnsRequest startLookup]: Performing DNS resolve: ows.messenger.msn.com:443
18:31:18: -[AdiumPurpleDnsRequest lookupFailedWithError:]: Failed lookup for ows.messenger.msn.com. Error domain 12, error 8
18:31:18: (Libpurple: dnsquery) Error resolving ows.messenger.msn.com:
nodename nor servname provided, or not known
18:31:18: (Libpurple: proxy) Connection attempt failed: Error resolving ows.messenger.msn.com:
nodename nor servname provided, or not known
18:31:18: (Libpurple: msn) cannot send OIM: Test

...which uses libpurple 2.7.11. I tried rolling back to Adium 1.3.5 - which uses libpurple 2.5.6 - and the same problem existed though no debug option (and so log) was available.

comment:11 Changed 8 years ago by jaymac407

This is RIDICULOUS pidgin!

This is a CONFIRMED BUG. Messages ARE NOT being sent. NO NOTIFICATION is being GIVEN.

This is the last straw I will put up with. I'll probably get a canned response like 'FIX IT YOURSELF LOL' -- I'm not a developer.

Anyway, I recommend the rest of you use aMSN for MSN from now on. It's been a nice few years pidgin, and I remember you all the back to gaim, but I'm sorry, it's time for us to part :(

comment:12 Changed 8 years ago by islandsword

Please fix this bug. Thanks.

comment:13 Changed 7 years ago by mikk

Confirmed, offline messages don't send, and no error messages. 2.10.0, Win7.

comment:14 Changed 7 years ago by QuLogic

Ticket #14854 has been marked as a duplicate of this ticket.

comment:15 Changed 7 years ago by qulogic@…

  • Milestone set to 3.0.0
  • Resolution set to fixed
  • Status changed from new to closed

(In ba1eb9b8a9a30e66ae62f2ee9e02571eb9ce27f5):
ChangeLog those last two changes.

Fixes #14302. Refs #14753.

comment:16 follow-up: Changed 7 years ago by qulogic@…

  • Milestone changed from 3.0.0 to 2.10.2

(In 5e6213531d20392ad819ad1bd7eaec4054b7079c):
* Plucked ba1eb9b8a9a30e66ae62f2ee9e02571eb9ce27f5 (qulogic@…): ChangeLog those last two changes.

Fixes #14302. Refs #14753.

comment:17 in reply to: ↑ 16 Changed 7 years ago by gd

Great
I've tried the patches and they work great, but I've noticed that when buddies log off or go invisible, their usernames are not parsed correctly in notification.c, so the buddy list keeps showing them as online.
Not sure if this is only happening to me, just wanted to report it before the release.

comment:18 Changed 7 years ago by QuLogic

Ticket #14984 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!