Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#14305 closed defect (fixed)

Pidgin Crash During Start on Ubuntu 11.04

Reported by: itcompozer Owned by: tomkiewicz
Milestone: 2.10.7 Component: Gadu-Gadu
Version: 2.10.4 Keywords: ubuntu gnome
Cc: tymik

Description

Hi, Pidgin Crash drugin Start. I have installed Pidgin 2.8 and it has started after these. Rolling back to 2.7.11 doesn't help. When i remove .purple folder Pidgin starts, but when I register my account there and download contact list from server, it crash. Yesterday before installing 2.8 was ok. I am attaching bactrace log to this ticket. Waiting for help.

Attachments (4)

gdb-pidgin.txt (6.9 KB) - added by itcompozer 5 years ago.
Backtrace Log
debug.log (355.0 KB) - added by itcompozer 5 years ago.
New Log which you wanted :)
pidgin-gg-ubuntu-crash.patch (1.2 KB) - added by tomkiewicz 5 years ago.
Cache purple_gnome_proxy_get_info calls
pidgin-gg-ubuntu-crash-2.patch (1.2 KB) - added by tomkiewicz 5 years ago.
Cache purple_gnome_proxy_get_info calls with 3 seconds data freshness

Download all attachments as: .zip

Change History (21)

Changed 5 years ago by itcompozer

Backtrace Log

comment:1 Changed 5 years ago by tomkiewicz

Related thread (in Polish): http://forum.pclab.pl/topic/701299-Pidgin-si%C4%99-wiesza/

This seems to be a problem with updating avatars.

I need some more information:

Changed 5 years ago by itcompozer

New Log which you wanted :)

comment:2 Changed 5 years ago by itcompozer

Okay, Hidding buddy list details doesn't help. I have attached new log to this ticket. Yours link doesn't work.

comment:3 Changed 5 years ago by itcompozer

  • Version changed from 2.8.0 to 2.9.0

comment:4 Changed 5 years ago by tomkiewicz

Sorry, I had no time before to look at this before.

I think, this can be a bug in libpurple - it queries OS for proxy every time, when it wants to get proxy config (without any cache). I have written small patch to cache this, but unfortunately I don't have gnome desktop, so it's untested.

Anyway, please try it and tell, if it helped.

Changed 5 years ago by tomkiewicz

Cache purple_gnome_proxy_get_info calls

comment:5 Changed 5 years ago by tomkiewicz

  • Keywords start pidgin 2.8 11.04 crash contact list removed

Tested today on 2.10.0 - works fine. But somebody (I don't remember, who) on IRC said, it shouldn't be fixed like that. It doesn't refresh proxy configuration after pidgin start.

Also, this is a (let's say) bug in Gadu-Gadu prpl, because it makes a lot of http queries (for avatars), which should be slowed down. Anyway - in my opinion, there are two bugs: in gg prpl and in proxy module. Caching fixed the second one. Cache could be invalidated after 10 seconds to allow pidgin react to system proxy configuration changes.

comment:6 Changed 5 years ago by tomkiewicz

  • Version changed from 2.9.0 to 2.10.0

comment:7 Changed 5 years ago by deryni

I commented that a fix that caches the proxy configuration for the lifespan of pidgin is unacceptable because it means pidgin can never react to system proxy changes.

It was also pointed out that under no circumstance should this be crashing, even under absolutely ludicrous numbers of calls to g_spawn_command_line_sync. It also appears to be the case that this is crashing inside of glib (or further down the stack) so there may or may not be anything pidgin/libpurple/gg can do about the actually issue.

A mitigation that throttles calls to fetch proxy information is certainly not out of line however, nor is seeing if there are ways to request to be notified of proxy configuration changes such that we can stop polling entirely.

Changed 5 years ago by tomkiewicz

Cache purple_gnome_proxy_get_info calls with 3 seconds data freshness

comment:8 Changed 5 years ago by tomkiewicz

  • Keywords gnome added

Could you check, if this one is proper way to cache it? In this version, data is valid only 3 seconds after retrieving it. Ways to request for proxy configuration updates could be a better solution, but it sounds way more complicated.

However, this patch is not yet tested in proper environment (but I'm in contact with somebody, who suffers of this bug). So, when somebody approve this way of fixing it, I will test it.

comment:9 Changed 5 years ago by tomkiewicz

  • Owner set to tomkiewicz

comment:10 Changed 5 years ago by tomkiewicz

Ticket #15132 has been marked as a duplicate of this ticket.

comment:11 Changed 5 years ago by tomkiewicz

  • Milestone set to 3.0.0
  • Version changed from 2.10.0 to 2.10.4

comment:12 Changed 4 years ago by tomkiewicz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 5a0c6582d5b1

comment:13 Changed 4 years ago by tomkiewicz

Ticket #15224 has been marked as a duplicate of this ticket.

comment:14 Changed 4 years ago by tomkiewicz

  • Milestone changed from 3.0.0 to 2.10.7

Also fixed in db3a62c8006c for 2.x.x branch.

comment:15 Changed 4 years ago by Tomasz Wasilczyk <tomkiewicz@…>

(In [5a0c6582d5b1]):
Gadu-Gadu: refactoring of buddy avatars handling. Fixes #13739, #14305

comment:16 Changed 4 years ago by tymik

And as my ticket #15407 was marked as duplicate I want to know why this ticket is closed and resolution says "fixed", when there is no 2.10.7 release yet? I don't know how you see the case, but for me problem is not fixed as long as fix is not released.

Anyways, could you hurry up with release? #15373 seems to be resolved(just not yet remarked), #15289 is related to Windows client (correct me if I'm mistaken) and I think it should not stop Linux release as it is not related, and #15029 might be moved to 3.0.0 as it is not so important to be done quickly(also possibly resolved, but I didn't check for files supported)? And it would be nice if comments could be placed under milestone, as a kind of discussion, because I find half of my comment not related to the ticket and no way under milestone to post it.

comment:17 Changed 4 years ago by tomkiewicz

That's how ticket system works - if a fix is committed into repository, ticket can be closed as fixed.

If you want to discuss about 2.10.7 release, please talk on devel@… xmpp MUC, or ask on devel mailing list.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!