Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14341 closed defect (fixed)

Pidgin 2.9.0 crashes opening irc chat channel...

Reported by: crusnik Owned by: darkrain42
Milestone: 2.10.0 Component: IRC
Version: 2.9.0 Keywords: Crash
Cc: elb

Description (last modified by darkrain42)

It's a clean install, but it crashed right away opening an irc channel @rizon I had no problems with previous versions.

Looked around in the debug file, found it was missing files, googled, found similar problem for the 2.7 version, added that .dll, didn't work.

Searched your database for this problem, couldn't find it, hence this new ticket.

Attachments (4)

pidgin.RPT (3.5 KB) - added by crusnik 8 years ago.
pidgin.rpt
debug_saved.txt (22.4 KB) - added by crusnik 8 years ago.
debuglog
pidgin_debug.log (16.6 KB) - added by Humancell 8 years ago.
Debug Trace for darkrain ... IRC #gg crash
backtrace.txt (5.5 KB) - added by darkrain42 8 years ago.
Backtrace from gdb

Download all attachments as: .zip

Change History (24)

Changed 8 years ago by crusnik

pidgin.rpt

comment:1 Changed 8 years ago by darkrain42

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:2 Changed 8 years ago by darkrain42

  • Owner changed from elb to darkrain42

comment:3 follow-up: Changed 8 years ago by darkrain42

Alternately, what channel are you joining? (so that I can reproduce this)

Changed 8 years ago by crusnik

debuglog

comment:4 Changed 8 years ago by crusnik

  • Status changed from pending to new

Attachment (debug_saved.txt) added by ticket reporter.

comment:6 in reply to: ↑ 3 Changed 8 years ago by crusnik

  • Description modified (diff)

Replying to darkrain42:

Alternately, what channel are you joining? (so that I can reproduce this)

The chatroom is #gg irc.rizon.net

comment:7 Changed 8 years ago by darkrain42

  • Description modified (diff)

comment:8 Changed 8 years ago by darkrain42

  • Status changed from new to pending

So, looking at the debug log; it looks like Pidgin ran successfully (and then you quit it). Did you join #gg?

This crash is related to the userlist (rearchitecting went into 2.9.0), so this may well be related to a specific user in the room.

(I also couldn't reproduce the crash joining #gg)

Changed 8 years ago by Humancell

Debug Trace for darkrain ... IRC #gg crash

comment:9 Changed 8 years ago by darkrain42

  • Status changed from pending to new

HumanCell's test was done on Windows with UTF-8 encoding and "Auto-detect" not checked.

This may well be either glib-version specific, or specific to Windows. Last log:

(23:31:29) GLib: g_convert: assertion `str != NULL' failed

Changed 8 years ago by darkrain42

Backtrace from gdb

comment:10 Changed 8 years ago by darkrain42

I've set up a Windows build environment and debugged this with gdb (backtrace attached).

This is crashing on g_utf8_collate_key("Chaotic Neutral", -1) (and the string is null-terminated).

I frankly have no idea what's going on here.

comment:11 Changed 8 years ago by darkrain42

  • Cc elb added

QuLogic helpfully pointed out the space in the nick didn't look right (...which it doesn't, when I view it in FF or anything other than faux-cmd.exe and notepad++).

This space is actually 0xA0 (160) a.k.a. NBSP.

elb, I'm hoping you've got an idea now.

comment:12 Changed 8 years ago by Plexus

do have the same error on 2 different win7 64bit machines, trying to enter the Chaoz-IRC.net...

here is last piece ot the dump: http://pastebin.com/F7SjRZsV

comment:13 Changed 8 years ago by Plexus

Did some further research and was able to narrow down the point when pidgin crashes. I had no problems to connect to the server itself or acquire the chanlist via /list-command. The automated login was performed and got confirmed by nickserv. At this point this is what debug output looks like: http://pastebin.com/NK52dM2L

There is no problem to join most channels but as soon as I connect some distinct channels these are the last lines to see before pidgin is crashed:

(22:00:43) gtkspell: Failed to setup GtkSpell?: enchant error for language: en (22:00:43) gtkspell: Failed to setup GtkSpell?: enchant error for language: en (22:00:43) GLib: g_convert: assertion `str != NULL' failed

To come to an end here is the content of pidgin.RTP http://pastebin.com/s4Lmn360

hope that helps...

greetz, plex

comment:14 follow-up: Changed 8 years ago by darkrain42

Hi folks!

I can no longer reproduce this on the reporter's server/channel (the user in question likely no longer in the channel). Can anyone else provide me with a server/channel on which I can test this?

Thanks!

comment:15 in reply to: ↑ 14 Changed 8 years ago by mesb

Replying to darkrain42:

Hi folks!

I can no longer reproduce this on the reporter's server/channel (the user in question likely no longer in the channel). Can anyone else provide me with a server/channel on which I can test this?

Thanks!

I have same problem. Windows 7 starter Pidgin 2.9.0 for windows

Now i reproduce it on:

server: irc.kgts.ru
port 6669
codepage cp1251
channel #kazan

After connecting pidgin is ok, but right after join to that chan it crashes.

comment:16 follow-up: Changed 8 years ago by MarkDoliner

Hey guys, thanks for helping us track down this issue. We haven't committed a fix yet, but I think we know how we're going to fix it. We'll try to get the fix checked in soon.

crusnik: Would it be ok if we credited you with finding this bug? If so, do you have a real name we could use?

comment:17 in reply to: ↑ 16 Changed 8 years ago by crusnik

Replying to MarkDoliner:

Hey guys, thanks for helping us track down this issue. We haven't committed a fix yet, but I think we know how we're going to fix it. We'll try to get the fix checked in soon.

crusnik: Would it be ok if we credited you with finding this bug? If so, do you have a real name we could use?

Finding bugs is what I do :) Glad I could help and hope you'll be able to fix it. I enjoy your product a lot, keep up the good work.

Djego Ibanez
Lead QA
Gamistry

comment:18 Changed 8 years ago by markdoliner@…

  • Milestone set to 2.9.1
  • Resolution set to fixed
  • Status changed from new to closed

(In 5c2dba4a7e2e76b76e7f472b88953a4316706d43):
Fix a crash when remote users have certain characters in their nicknames. (Discovered by Djego Ibanez) Fixes #14341

comment:19 Changed 8 years ago by thijsalkemade@…

(In c03d69f8e866e1e33d6cb47455b2c5ff0c9e1e7f):
applied changes from 29484df15413fe3bbd21bbfcef26a55362055a81

through 5749f9193063800d27bef75c2388f6f9cc2f7f37

applied changes from 5749f9193063800d27bef75c2388f6f9cc2f7f37

through 5c2dba4a7e2e76b76e7f472b88953a4316706d43

* Plucked 5c2dba4a7e2e76b76e7f472b88953a4316706d43 (markdoliner@…): Fix a crash when remote users have certain characters in their nicknames. (Discovered by Djego Ibanez) Fixes #14341

comment:20 Changed 8 years ago by Robby

  • Milestone changed from 2.9.1 to v2.10.1

comment:21 Changed 8 years ago by MarkDoliner

  • Milestone changed from v2.10.1 to 2.10.0

Oh, this actually got released in 2.10.0. /me goes to check if any other tickets have milestone 2.9.1

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!