Opened 5 years ago

Closed 5 years ago

#14488 closed defect (duplicate)

Intermittent crashes, related to MSN?

Reported by: mgroves Owned by: QuLogic
Milestone: Component: MSN
Version: 2.9.0 Keywords:
Cc:

Description (last modified by mgroves)

Pidgin started crashing at seemingly random times. I tried a reinstall of Pidgin (with debug symbols this time) and at first that seemed to fix it, but just now I got another crash. Here's the latest from pidgin.rpt:

Error occured on Thursday, August 4, 2011 at 10:17:25.

Windows Version 6.1 Build 7601 Service Pack 1

C:\Program Files (x86)\Pidgin\pidgin.exe caused an Access Violation at location 6b89bc8c in module C:\Program Files (x86)\Pidgin\plugins\libmsn.dll Reading from location 00000005.

Registers:
eax=00000005 ebx=00000000 ecx=000004b2 edx=00000005 esi=06668d30 edi=00007712
eip=6b89bc8c esp=0028c7a8 ebp=0028c7c0 iopl=0         nv up ei pl zr na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00210246

Call stack:
         Using Debug Symbols from: C:\Program Files (x86)\Pidgin\pidgin-2.9.0-dbgsym\plugins\libmsn.dll.dbgsym
6B89BC8C C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msn_p2p_info_get_session_id  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/p2p.c:520
6B8A0ABD C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msn_slplink_process_msg  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/slplink.c:433
6B88173C C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msn_cmdproc_process_msg  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/cmdproc.c:270
6B8A48F9 C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msg_cmd_post  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/switchboard.c:695
6B881595 C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msn_cmdproc_process_payload  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/cmdproc.c:178
6B89CCBC C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  msn_servconn_process_data  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/servconn.c:490
6B89CE60 C:\Program Files (x86)\Pidgin\plugins\libmsn.dll  read_cb  E:/pidgin-build/pidgin-2.9.0/libpurple/protocols/msn/servconn.c:446
         C:\Program Files (x86)\Pidgin\pidgin.dll [2.9.0.0]
         Using Debug Symbols from: C:\Program Files (x86)\Pidgin\pidgin-2.9.0-dbgsym\pidgin.dll.dbgsym
64A7C652 C:\Program Files (x86)\Pidgin\pidgin.dll  pidgin_io_invoke  E:/pidgin-build/pidgin-2.9.0/pidgin/gtkeventloop.c:77
         C:\Program Files (x86)\Pidgin\Gtk\bin\libglib-2.0-0.dll [2.20.5.0]
685EA27B C:\Program Files (x86)\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_context_dispatch
685ED185 C:\Program Files (x86)\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_context_prepare
685ED574 C:\Program Files (x86)\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_loop_run
         C:\Program Files (x86)\Pidgin\Gtk\bin\libgtk-win32-2.0-0.dll [2.16.6.0]
02334260 C:\Program Files (x86)\Pidgin\Gtk\bin\libgtk-win32-2.0-0.dll  gtk_main
         C:\Program Files (x86)\Pidgin\pidgin.dll [2.9.0.0]
         Using Debug Symbols from: C:\Program Files (x86)\Pidgin\pidgin-2.9.0-dbgsym\pidgin.dll.dbgsym
64A97D08 C:\Program Files (x86)\Pidgin\pidgin.dll  pidgin_main  E:/pidgin-build/pidgin-2.9.0/pidgin/gtkmain.c:944
         C:\Program Files (x86)\Pidgin\pidgin.exe [2.9.0.0]
         Using Debug Symbols from: C:\Program Files (x86)\Pidgin\pidgin-2.9.0-dbgsym\pidgin.exe.dbgsym
0040250B C:\Program Files (x86)\Pidgin\pidgin.exe  WinMain  E:/pidgin-build/pidgin-2.9.0/pidgin/win32/winpidgin.c:821
00402E58 C:\Program Files (x86)\Pidgin\pidgin.exe  WinMain  E:/pidgin-build/pidgin-2.9.0/pidgin/win32/winpidgin.c:726
0040124B C:\Program Files (x86)\Pidgin\pidgin.exe
004012B8 C:\Program Files (x86)\Pidgin\pidgin.exe
         C:\Windows\syswow64\kernel32.dll [6.1.7601.17617]
76C4339A C:\Windows\syswow64\kernel32.dll  BaseThreadInitThunk
         C:\Windows\SysWOW64\ntdll.dll [6.1.7601.17514]
77659ED2 C:\Windows\SysWOW64\ntdll.dll  RtlInitializeExceptionChain
77659EA5 C:\Windows\SysWOW64\ntdll.dll  RtlInitializeExceptionChain

Looks like it's libmsn.dll?

Change History (2)

comment:1 Changed 5 years ago by mgroves

  • Description modified (diff)

comment:2 Changed 5 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #14307.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!