Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14490 closed defect (fixed)

Version mismatch Pidgin / plugins

Reported by: spallared Owned by:
Milestone: Component: plugins
Version: 2.9.0 Keywords: plugin version mismatch
Cc:

Description (last modified by QuLogic)

Hello, i recently built Pidgin 2.9.0 and its plugin from source on a Ubuntu 11.04 x64 machine previously running Pidgin 2.7.2 taken from Ubuntu's repos.

Everything works except some plugins (i.e: history, message notification...) doesn't works because they states:

Error: ABI version mismatch 2.9.x (need 2.7.x)
Check the plugin website for an update.

I tried to modify plugin sources in order to force 2.7.x version, modifying:

static PurplePluginInfo info =
{
        PURPLE_PLUGIN_MAGIC,
        PURPLE_MAJOR_VERSION,
        PURPLE_MINOR_VERSION,
        PURPLE_PLUGIN_STANDARD, 
[..]

into:

static PurplePluginInfo info =
{
        PURPLE_PLUGIN_MAGIC,
        PURPLE_MAJOR_VERSION,
        7,
        PURPLE_PLUGIN_STANDARD, 
[..]

... and the plugin runs fine!

Don't know if this issue is related to the previous installation of Pidgin 2.7.2 but notice that before installing 2.9.0 previous version was removed.

Regards Luca

Change History (4)

comment:1 Changed 6 years ago by datallah

  • Status changed from new to pending

Are you sure that you're actually running with libpurple 2.9.0? Check Help->Build Information

It looks like you're using 2.7.x.

comment:2 Changed 6 years ago by spallared

  • Resolution set to fixed
  • Status changed from pending to closed

You're right... libpurple is 2.7.11 but i had to manually copy libpurple files from ./libs to my usr/lib because make install did not make this for me...:?

Regards Luca

comment:3 Changed 6 years ago by datallah

By default pidgin from source will install to /usr/local prefix instead of /usr because that's where stuff installed from source *should* go.

Copying files around isn't really a good idea.

The correct solution is probably to remove the Pidgin/Libpurple? installed from the package if you want to use the source installed version.

Alternatively, you probably just could run sudo ldconfig.

comment:4 Changed 6 years ago by QuLogic

  • Description modified (diff)
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!