Changes between Initial Version and Version 4 of Ticket #14490


Ignore:
Timestamp:
08/16/11 15:09:41 (8 years ago)
Author:
QuLogic
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #14490

    • Property Status changed from new to closed
    • Property Resolution changed from to fixed
  • Ticket #14490 – Description

    initial v4  
    33Everything works except some plugins (i.e: history, message notification...) doesn't works because they states:
    44
    5 ''Error: ABI version mismatch 2.9.x (need 2.7.x)
     5{{{
     6Error: ABI version mismatch 2.9.x (need 2.7.x)
    67Check the plugin website for an update.
    7 ''
     8}}}
    89
    910I tried to modify plugin sources in order to force 2.7.x version, modifying:
    1011
    11 ''static PurplePluginInfo info =
     12{{{
     13static PurplePluginInfo info =
    1214{
    1315        PURPLE_PLUGIN_MAGIC,
     
    1517        PURPLE_MINOR_VERSION,
    1618        PURPLE_PLUGIN_STANDARD,
    17 [..]''
     19[..]
     20}}}
    1821
    1922into:
    2023
    21 ''static PurplePluginInfo info =
     24{{{
     25static PurplePluginInfo info =
    2226{
    2327        PURPLE_PLUGIN_MAGIC,
    2428        PURPLE_MAJOR_VERSION,
    25         '''7''',
     29        7,
    2630        PURPLE_PLUGIN_STANDARD,
    27 [..]''
     31[..]
     32}}}
    2833
    2934... and the plugin runs fine!
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!