Opened 5 years ago

Closed 5 years ago

#14508 closed defect (duplicate)

Crash on certain words with icons

Reported by: polleke Owned by: QuLogic
Milestone: Component: MSN
Version: 2.9.0 Keywords:
Cc:

Description (last modified by polleke)

I'm using Pidgin 2.9.0 on Fedora 15. Since a recent update I'm having crashes when someone uses the word "haha" or "doei" (Dutch for bye). I can see it try to load an icon, and then the program all disappears.

The other side is using Windows XP with Messenger. Today I had another friend try out "haha" and it didn't crash, but it did crash on "doei". He is using Windows 7 with the standard Messenger.

I'm using a hotmail account on MSN, both other accounts are hotmail accounts as well.

I made a backtrace, I hope it's usefull:

(gdb) bt full #0 msn_p2p_info_get_session_id (info=0x31) at p2p.c:520

session_id = <optimized out>

#1 0x00007fffe9cc8549 in msn_slplink_message_find (id=13337269, session_id=180643344, slplink=0x1bf42e0)

at slplink.c:433

slpmsg = 0x1b53540 e = 0x1b5a300 = {0x1b53540, 0x1c0f2c0, 0x1a2de30, 0x1a1a6a0, 0xa5d340}

#2 msn_slplink_process_msg (slplink=0x1bf42e0, part=0x1bdb9c0) at slplink.c:582

session_id = 180643344 id = 13337269 slpmsg = <optimized out> info = 0x1a85980

#3 0x00007fffe9ca3a6b in msn_cmdproc_process_msg (cmdproc=0x1bf3a60, msg=0x1c76210) at cmdproc.c:265

cb = <optimized out> message_id = 0x0

#4 0x00007fffe9ccc0ff in msg_cmd_post (cmdproc=0x1bf3a60, cmd=0x1c0f350, payload=

0x1c13459 "MIME-Version: 1.0\r\nContent-Type: application/x-msnmsgrp2p\r\nP2P-Dest: xxx@…\r\nP2P-Src: xxx@…\r\n\r\n\020f\304\n\265\202", <incomplete sequence \313>, len=1383) at switchboard.c:693

msg = 0x1c76210

#5 0x00007fffe9cc3e16 in msn_servconn_process_data (servconn=0x1c0e8a0) at servconn.c:489

cur =

0x1c13459 "MIME-Version: 1.0\r\nContent-Type: application/x-msnmsgrp2p\r\nP2P-Dest: xxx@…\r\nP2P-Src: xxx@…\r\n\r\n\020f\304\n\265\202", <incomplete sequence \313>

end = 0x1c139c0 "" old_rx_buf = 0x1c13430 "MSG xxx@… Robert 1383" cur_len = <optimized out>

#6 0x00007fffe9cc3fc6 in read_cb (data=0x1c0e8a0, source=<optimized out>, cond=<optimized out>)

at servconn.c:445

servconn = 0x1c0e8a0 buf =

"MSG xxx@… Robert 1383\r\nMIME-Version: 1.0\r\nContent-Type: application/x-msnmsgrp2p\r\nP2P-Dest: xxx@…\r\nP2P-Src: xxx@…\r\n\r\n\020f\304\n\265\202\313\000\262\004\000\000\000\000\000\000\250\067\000\000\000\000\000\000\262\004\000\000 \000\000\001 b\336", '\000' <repeats 13 times>...

len = 1424

#7 0x000000000047342e in pidgin_io_invoke (source=<optimized out>, condition=<optimized out>, data=0x1ac4a90)

at gtkeventloop.c:73

closure = 0x1ac4a90 purple_cond = PURPLE_INPUT_READ

#8 0x0000003315a427ed in g_main_dispatch (context=0x70a090) at gmain.c:2441

dispatch = 0x3315a84ad0 <g_io_unix_dispatch> was_in_call = 0 user_data = 0x1ac4a90 callback = 0x4733e0 <pidgin_io_invoke> cb_funcs = 0x3315d15c50 cb_data = 0x1aec310 current_source_link = {data = 0x1ac4d90, next = 0x0} need_destroy = <optimized out> source = 0x1ac4d90 current = 0xc49200 i = <optimized out>

#9 g_main_context_dispatch (context=0x70a090) at gmain.c:3014 No locals. #10 0x0000003315a42fc8 in g_main_context_iterate (context=0x70a090, block=<optimized out>, dispatch=1,

self=<optimized out>) at gmain.c:3092

max_priority = 2147483647 timeout = 33 some_ready = 1 nfds = 15 allocated_nfds = <optimized out> fds = <optimized out> PRETTY_FUNCTION = "g_main_context_iterate"

#11 0x0000003315a4360d in g_main_loop_run (loop=0x19c5680) at gmain.c:3300

self = 0x704010 PRETTY_FUNCTION = "g_main_loop_run"

#12 0x00007ffff76ab007 in IAgtk_main () at gtkmain.c:1256

tmp_list = <optimized out> functions = 0x0 init = <optimized out> loop = 0x19c5680

#13 0x0000000000431498 in main (argc=1, argv=0x7fffffffe4d8) at gtkmain.c:934

opt_force_online = 0 opt_help = <optimized out> opt_login = 0 opt_nologin = 0 opt_version = <optimized out> opt_si = 1 opt_config_dir_arg = <optimized out> opt_login_arg = <optimized out> opt_session_arg = <optimized out> search_path = <optimized out> accounts = <optimized out> sig_indx = 1 sigset = {val = {82950, 0 <repeats 15 times>}} prev_sig_disp = <optimized out> errmsg =

"\310\364\374\367\377\177\000\000\000\000\000\000\000\000\000\000\220\304\377\377\377\177\000\000\065L\340\030\063\000\000\000\310i\375\367\377\177\000\000\000\000\300\206\377\377\377\377\000\000V\202\275\357\377\377\274\220\004\000\001\220\000\000\315\027\032\nD0\300\026\000\342\377\377\377\177\000\000\200\342\377\377\377\177\000\000\a\000\000\000\000\000\000\000p\305\377\377\377\177\000\000Sy\340\033\063\000\000\000\330d\375\367\377\177\000\000\022\241\336\367\377\177\000\000\000\000\000\000\000\000\000\000F\301\336\367\377\177\000\000\210\340\377\367\377\177\000\000@\342\377\377\377\177\000\000\060\342\377\377\377\177\000\000O\342\377\377\377\177\000\000\340\240\336\367\377\177\000\000\000\342\377\377\377\177\000\000\035\000\000\000 \000\000\000\230\262\t\031\063\000\000\000\200\342\377\377\377\177\000\000\005\251\336\367\377\177\000\000\310\364\374\367\377\177\000\000\000\000\000\000\000\000\000\000p\305\377\377\377\177\000\000Sy\340\033\063\000\000\000\330d\375\367\377\177\000\000\000\000\200\210\377\377\377\377\000\000V\202\275\357\377\377\000\000\000\000C\000\000\000G\000\000\000J\000\000\000\000\000\000\000K\000\000\000M\000\000\000Q\000\000\000R\000\000\000S\000\000\000"...

signal_channel = <optimized out> signal_status = <optimized out> signal_channel_watcher = 1 segfault_message_tmp = <optimized out> error = 0x0 opt = <optimized out> gui_check = <optimized out> debug_enabled = -15512 migration_failed = <optimized out> active_accounts = <optimized out> st = {st_dev = 140737353950432, st_ino = 140737353951672, st_nlink = 140737353945088, st_mode =

4160558296, st_uid = 32767, st_gid = 4160559520, pad0 = 32767, st_rdev = 140737353940992, st_size = 140737353942216, st_blksize = 140737353943440, st_blocks = 140737353936896, st_atim = {tv_sec = 140737353938120, tv_nsec = 0}, st_mtim = {tv_sec = 219456484958, tv_nsec = 140737353961472}, st_ctim = {

tv_sec = -2071986176, tv_nsec = -17877762179072}, unused = {1, 140737488339872, 219456484944}}

long_options = {{name = 0x4e2a7c "config", has_arg = 1, flag = 0x0, val = 99}, {name =

0x4cd33a "debug", has_arg = 0, flag = 0x0, val = 100}, {name = 0x4ddea9 "force-online", has_arg = 0,

flag = 0x0, val = 102}, {name = 0x4d09ff "help", has_arg = 0, flag = 0x0, val = 104}, {name =

0x4ddc6d "login", has_arg = 2, flag = 0x0, val = 108}, {name = 0x4ddeb6 "multiple", has_arg = 0, flag = 0x0, val = 109}, {name = 0x4ddebf "nologin", has_arg = 0, flag = 0x0, val = 110}, {name = 0x4e2a72 "session", has_arg = 1, flag = 0x0, val = 115}, {name = 0x4d47b4 "version", has_arg = 0, flag = 0x0, val = 118}, {name = 0x4e2a85 "display", has_arg = 1, flag = 0x0, val = 68}, {name = 0x4ddec7 "sync",

has_arg = 0, flag = 0x0, val = 83}, {name = 0x0, has_arg = 0, flag = 0x0, val = 0}}

(gdb) quit

Attachments (1)

pidgin.log (6.7 KB) - added by polleke 5 years ago.
Backtrace in textfile

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by polleke

  • Description modified (diff)

Changed 5 years ago by polleke

Backtrace in textfile

comment:2 Changed 5 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #14307.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!