Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#1459 closed defect (invalid)

Yahoo buddies do not receive /buzz sent from me

Reported by: andrixnet Owned by:
Milestone: Component: libpurple
Version: 2.0.1 Keywords:
Cc:

Description

I'm using Pidgin. Yahoo proto. Assume talking to some buddies that use yahoo official client. versions 7.*, 8.*.

When a buddy sends me a buzz, I see in conversation window this : XXXXXXX just sent you a Buzz'''

When I want to send a buzz to someone (yes, that person is also online), I type

/buzz

in conversation window. Pidgin displays this for me : You have just sent a Buzz'''

However, that buddy receives NOTHING.

Change History (10)

comment:1 Changed 10 years ago by datallah

  • Component changed from winpidgin (gtk) to libpurple
  • Owner datallah deleted

comment:2 Changed 10 years ago by lschiere

  • Milestone set to 2.1.2

comment:3 Changed 10 years ago by datallah

  • pending changed from 0 to 1

I just tested sending a buzz from Pidgin to the version 8.1.0.402 yahoo client and it works fine.

comment:4 Changed 10 years ago by andrixnet

  • pending changed from 1 to 0

tested with pidgin 2.1.0, buzzing myself (i got my user in the list as well), I don't receive the buzz back.

Just tested against another friend with official yahoo client 8.1. He did NOT receive any buzz.

comment:5 Changed 10 years ago by datallah

  • pending changed from 0 to 1

The server appears to restrict the number of buzzes you can send within a certain timeframe (the native client must keep track of this too and disables the "Buzz" menu item). If you send several buzzes in quick succession, pidgin has no idea that the server is eating them (this may or may not be your problem).

All i can say is that if I wait a minute or so between buzzes, it works just fine.

What does the debug log say when you send the buzz?

comment:6 Changed 10 years ago by andrixnet

  • pending changed from 1 to 0

(22:43:08) util: Writing file pounces.xml to directory C:\WINDOWS\Application Data\.purple (22:43:09) util: Writing file accounts.xml to directory C:\WINDOWS\Application Data\.purple (22:43:09) util: Writing file blist.xml to directory C:\WINDOWS\Application Data\.purple (22:43:09) util: Writing file status.xml to directory C:\WINDOWS\Application Data\.purple (22:43:09) util: Writing file prefs.xml to directory C:\WINDOWS\Application Data\.purple (22:43:10) yahoo: 54 bytes to read, rxlen is 74 (22:43:10) yahoo: Yahoo Service: 0x4b Status: 1 (22:43:12) yahoo: Sending <ding> on account andrixnet to buddy andrixnet. (22:43:12) purple-splitter: splitter plugin invoked (22:43:12) yahoo: 54 bytes to read, rxlen is 74 (22:43:12) yahoo: Yahoo Service: 0x4b Status: 1 (22:43:14) accels: accel changed, scheduling save. (22:43:14) accels: accel changed, scheduling save. (22:43:14) accels: accel changed, scheduling save.

comment:7 Changed 10 years ago by andrixnet

and the buzz signals I sent were several minutes apart so i don't think this might be an issue. (and AFAIK, the official Yahoo client disables the buzz for some time for the buddy I gave a buzz, but I can buzz others...)

comment:8 Changed 10 years ago by datallah

  • pending changed from 0 to 1

It looks like your "splitter plugin" might be getting in the way.

This is what my output looks like:

(16:05:26) yahoo: Sending <ding> on account "me" to buddy "me"
(16:05:26) yahoo: yahoo_html_to_codes:  Returning string: '<ding>'.

comment:9 Changed 10 years ago by andrixnet

  • pending changed from 1 to 0

I can confirm on Pidgin 2.0.2 (i just reverted back from 2.1.0 because it crashed a lot, but randomly) that with message splitter plugin deactivated, the buzz is received correctly.

comment:10 Changed 10 years ago by datallah

  • Milestone 2.1.2 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Cool.

You can report the bug to the plugin author if you want.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!