Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14680 closed defect (invalid)

Pidgin does not send a message through XMPP to Facebook chat (only receive a message is working)

Reported by: NPetr Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.0 Keywords: Facebook chat XMPP send direction error problem


From 13th October 2011 Pidgin does not send a message through XMPP to Facebook chat. More precisely the message sent from Pidgin looks OK, but this message is never delivered to our buddy to the Facebook chat even if we could see it in Pidgin messages history as a sent message. If we send a message through web interface of Facebook chat, everything is OK. Don't forget to mention if our buddy send us a message through web interface of Facebook chat, Pidgin receive it through XMPP without any problem. So that means send direction is broken, receive direction is OK. Thank you for any helps

Change History (13)

comment:1 Changed 5 years ago by NPetr

  • Keywords chat added

comment:2 Changed 5 years ago by Peter36317

I have the same problem.

comment:3 Changed 5 years ago by crq

I also have the same problem

comment:4 Changed 5 years ago by fixpidgin

same prob on windows. i tried uninstalling. didnt fix the prob. same prob reported here:

not a firewall prob. im SURE. fb chat on pidgin via xmpp simply...stopped. can only recieve, not send

comment:5 Changed 5 years ago by utrrrongeeb

I've observed the same problem: Pidgin logs in successfully, accurately populates the buddy list (online status is correct as well), and receives typing notifications and messages, but messages sent are not received, with no visible errors.

The problem can be reproduced with Pidgin on Debian and Windows, Empathy and Kopete on Debian, and iChat in Mac OS X; some testing has been done from other networks and accounts.

Looks like a problem in Facebook systems, not XMPP clients.

comment:6 Changed 5 years ago by crazedfred

It seems there are several open, unresolved tickets about this issue:

Needless to say, this is very frustrating; compatibility with Facebook chat is the main reason I use Pidgin. If possible, could someone confirm that the issue truly lies with Facebook, and that no workarounds exist?

This ticket is 3 months old; has Facebook been contacted asking about this issue? Are they even aware the problem exists?

comment:7 Changed 5 years ago by rtc

This is not a pidgin problem, it is a problem of your facebook privacy settings.

The problem occurs on all clients. However, linux users are generally both more privacy-aware and more likely to use jabber, so almost all users having this problem are linux users.

The cause of the proble is that you have changed your facebook privacy settings to "Turn off all apps" (under "Apps and Websites"). This will disable your ability to send messages via jabber, as well as to receive messages sent via jabber. (You are still able to send messages to jabber from the facebook web chat and receive such messages via jabber.)

To fix the problem, simply enable apps again. To keep your privacy, you might want to disable everything under the "How people bring your info to apps they use" setting, and to disable instant personalization (clicking "close" on the "Understanding Instant Personalization" pop-up, then see bottom of page), most of which will be enabled by default as a consequence of enabling apps.

Hope this helps.

comment:8 Changed 5 years ago by cobalt


Has revolved the issue for me.

comment:9 Changed 5 years ago by crazedfred

RTC's comment also worked for me; however, because this has clearly been asked several times, I felt this question and answer should definitely be added to the Facebook entry in the Pidgin FAQ.

I took the initiative of adding an FAQ entry (see "Why can't Pidgin seem to send Facebook messages?"):

Any feedback or improvements to that entry would be welcome. Once a developer is satisfied with the entry, please close this ticket.

comment:10 Changed 5 years ago by deryni

Ticket #14720 has been marked as a duplicate of this ticket.

comment:11 Changed 5 years ago by deryni

  • Resolution set to invalid
  • Status changed from new to closed

comment:12 Changed 5 years ago by crazedfred

deryni, please note that you have closed #14680 as a duplicate of #14720, while simultaneously closing #14720 as a duplicate of #14680. I would posit that this is impossible :)

However, due to my FAQ additions mentioned in 9, this should be resolved. If desired, please review the entry I added, as that was added unilaterally.

comment:13 Changed 5 years ago by deryni

Indeed. I believe I meant to close one of those as a duplicate of a third ticket, oh well.

I closed both of these because your FAQ addition covers the situation.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!