Opened 7 years ago

Closed 7 years ago

#14710 closed defect (invalid)

Pidgin crashes on start up

Reported by: sabresong Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.10.0 Keywords:
Cc:

Description

When trying to start Pidgin using the GUI, the buddy list window flashes on screen and then is gone, pidgin has instantly closed. When starting it from the command line, it returns that pidgin 2.7.3 has segfaulted and attempted to dump a core file.

Backtrace:

#0 0xb756d47a in vfprintf () from /lib/libc.so.6 No symbol table info available. #1 0xb758cc07 in vasprintf () from /lib/libc.so.6 No symbol table info available. #2 0xb77f12c7 in g_vasprintf () from /lib/libglib-2.0.so.0 No symbol table info available. #3 0xb77d00d6 in g_strdup_vprintf () from /lib/libglib-2.0.so.0 No symbol table info available. #4 0xb683f656 in skype_debug_vargs (level=PURPLE_DEBUG_ERROR,

category=0xb684a119 "skype", format=0xb6849876 "Could not start skype: %s\n", args=0xbfffd0e8 "&") at debug.c:102

No locals. #5 0xb683f723 in skype_debug_error (category=0xb684a119 "skype",

format=0xb6849876 "Could not start skype: %s\n") at debug.c:72

No locals. #6 0xb68441cd in exec_skype (acct=0x81af4e8) at skype_messaging_x11.c:325

error = 0xb76fb2a3

#7 skype_login (acct=0x81af4e8) at libskype.c:1487

gc = 0x871d900 reply = <value optimized out>

#8 0xb76beb7f in _purple_connection_new (account=0x81af4e8, regist=0,

password=0x0) at /build/buildd-pidgin_2.7.3-1+squeeze1-i386-HtGK4y/pidgin-2.7.3/./libpurple/connection.c:171

gc = 0x871d900 prpl = <value optimized out> prpl_info = 0xb684b5e0 PRETTY_FUNCTION = "_purple_connection_new"

#9 0xb76a8104 in purple_account_connect (account=0x81af4e8)

at /build/buildd-pidgin_2.7.3-1+squeeze1-i386-HtGK4y/pidgin-2.7.3/./libpurple/account.c:1215

prpl = 0x0 password = 0x0 username = <value optimized out> PRETTY_FUNCTION = "purple_account_connect"

#10 0xb76a8285 in purple_accounts_restore_current_statuses ()

at /build/buildd-pidgin_2.7.3-1+squeeze1-i386-HtGK4y/pidgin-2.7.3/./libpurple/account.c:2902

l = <value optimized out> account = 0x81af4e8

#11 0x080caecb in main (argc=1, argv=0xbffff524)

at /build/buildd-pidgin_2.7.3-1+squeeze1-i386-HtGK4y/pidgin-2.7.3/./pidgin/gtkmain.c:958

opt_force_online = 0 opt_help = 136031744 opt_login = 0 opt_nologin = 0 opt_version = 0 opt_si = 1 opt_config_dir_arg = 0x0 opt_login_arg = 0x0 opt_session_arg = 0x0 search_path = <value optimized out> accounts = <value optimized out> sig_indx = <value optimized out> sigset = {val = {82950, 0 <repeats 31 times>}} prev_sig_disp = <value optimized out> errmsg = " \226\030\267\260\222\030\267\270\242\367\267\210-\214\267\000\000\000\000\366\a\377\267<\363\377\277", '\000' <repeats 12 times>, "_\363\377\277X\363\377\277Ax\377\267L\370\377\267\001\000\000\000 \360\377\267\000\000\000\000\230\341\030\267\364\357\377\267\364\357\377\267 \323\377\277\005\000\000\000\374\322\377\277ey\377\267\b\000\000\000h\252\372\266\024\000\000\000l\363\377\277>\362\376\267\200\252\372\266h\252\372\266\024\000\000\000\000\000\000\000\000\000\000\001\000\000\000\000 \324\377\277в<\267 \226\030\267\270\242\367\267\210-\214\267\000\000\000\000\000\000\000\000_\363\377\277X\363\377\277T\363\377\277Ax\377\267(\246\372\266\001\000\000\000\000\000\000\000\320\030\032\267\364\357\377\267P\376\376\267\364\357\377\267\240\323\377\277\004\000\000\000\200\323\377\277ey\377\267\b\000\000\000@\252\372\266\020\000\000\000l\363\377\277>\362\376\267T\252\372\266@\252\372\266\020\000\000\000\000@\002\001\000\000\000\000\240\324\377\277\270\242\367\267в<\267\210-\214\267\000\000\000\000\254_\002\000\264_\002\000_\363\377\277X\363\377\277T\363\377\277Ax\377\267\001\000\000\000 \360\377\267\000\000\000\000\360\323\377\277\364\357\377\267P\376\376\267\364\357\377\267 \324\377\277\004\000\000\000\000\324\377\277ey\377\267\b\000\000\000\030\252\372\266\020\000\000\000l\363\377\277>\362\376\267,\252\372\266\030\252\372\266\020\000\000\000\000\000\000\000 \325\377\277\374\324\377\277\270\242\367\267в<\267\210-\214\267\000\000\000\000\006\000\000\000"... signal_channel = <value optimized out> signal_status = <value optimized out> signal_channel_watcher = 1 error = 0x0 opt = <value optimized out> gui_check = <value optimized out> debug_enabled = 0 migration_failed = 136031744 active_accounts = <value optimized out> st = {st_dev = 13210077040390577057, pad1 = 3208, st_ino = 1,

st_mode = 3087003636, st_nlink = 3221222608, st_uid = 3087006384, st_gid = 3221222564, st_rdev = 13835045499884716610, pad2 = 3208, st_size = -5188153003802102648, st_blksize = 0, st_blocks = 7364849552, st_atim = {tv_sec = 0, tv_nsec = 1}, st_mtim = {tv_sec = -1207961352, tv_nsec = 255}, st_ctim = {

tv_sec = 4096, tv_nsec = -1219116699}, st_ino = 0}

long_options = {{name = 0x811bdca "config", has_arg = 1, flag = 0x0,

val = 99}, {name = 0x8108d9d "debug", has_arg = 0, flag = 0x0, val = 100}, {name = 0x8117634 "force-online", has_arg = 0, flag = 0x0, val = 100}, {name = 0x810b9d7 "help", has_arg = 0, flag = 0x0, val = 104}, {name = 0x8117400 "login", has_arg = 2, flag = 0x0, val = 108}, {name = 0x8117641 "multiple", has_arg = 0, flag = 0x0, val = 109}, {name = 0x811764a "nologin", has_arg = 0, flag = 0x0, val = 110}, {name = 0x811bdc0 "session", has_arg = 1, flag = 0x0, val = 115}, {name = 0x810eb3d "version", has_arg = 0, flag = 0x0, val = 118}, {name = 0x811bdd3 "display", has_arg = 1, flag = 0x0, val = 68}, {name = 0x8117652 "sync", has_arg = 0, flag = 0x0, val = 83}, {name = 0x0, has_arg = 0, flag = 0x0, val = 0}}

Change History (2)

comment:1 Changed 7 years ago by no_se

This pretty much looks like a skype related issue. First: skype has to run on your machine, if you want pidgin to talk with it.

Second: If you think this is a pidgin bug, deactivate all non-core plugins (i.e. the skype plugin) and retry starting pidgin. If you can't get to the plugins menu, try pidgin --nologin

comment:2 Changed 7 years ago by rekkanoryo

  • Resolution set to invalid
  • Status changed from new to closed

This issue is caused by a third party plugin. We have no control over these plugins. Please report this problem to the authors of this third party plugin.

The Skype plugin is the problem here. Get rid of it or contact the plugin's author(s) to resolve the issue.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!