Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14781 closed defect (invalid)

Facebook XMPP silently drops messages.

Reported by: cobalt Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.0 Keywords: libpurple XMPP Facebook message
Cc:

Description

Starting about 6-8 weeks ago, using XMPP to connect to Facebook has not been delivering messages to recipients.

The only thing that shows up in the debug log is something like the following:

(22:21:06) jabber: Unable to find caps: nothing known about buddy (22:21:06) jabber: Sending (ssl) (my.username@…/f26d0771_4B331A9DAA7DE): <message type='chat' id='purplea35b3720' to='recipient.id@…'><active xmlns='http://jabber.org/protocol/chatstates'/><body>Hello there.</body></message> (22:21:06) jabber: Sending (ssl) (my.username@…/f26d0771_4B331A9DAA7DE): <message type='chat' id='purplea35b3721' to='recipient.id@…'><active xmlns='http://jabber.org/protocol/chatstates'/></message>

Change History (7)

comment:1 Changed 6 years ago by Robby

This is known to be an issue on Facebook's side.

comment:2 Changed 6 years ago by deryni

  • Keywords message added
  • Status changed from new to pending

Do we know that? I know we believe that (since there has never been any indication at the xmpp level that anything has gone wrong). This is a duplicate ticket though I can't find the others at the moment.

comment:3 Changed 6 years ago by cobalt

  • Status changed from pending to new

http://developer.pidgin.im/ticket/14680

Although I think mine is nicer. Whether the issue is with Facebook or Pidgin, shouldn't there be some indication things are not working properly? Something in the message window would be nice if at all possible. I went a few weeks before realising anything was the matter.

comment:4 follow-up: Changed 6 years ago by rtc

This is not a pidgin problem, it is a problem of your facebook privacy settings.

The problem occurs on all clients. However, linux users are generally both more privacy-aware and more likely to use jabber, so almost all users having this problem are linux users.

The cause of the proble is that you have changed your facebook privacy settings to "Turn off all apps" (under "Apps and Websites"). This will disable your ability to send messages via jabber, as well as to receive messages sent via jabber. (You are still able to send messages to jabber from the facebook web chat and receive such messages via jabber.)

To fix the problem, simply enable apps again. To keep your privacy, you might want to disable everything under the "How people bring your info to apps they use" setting, and to disable instant personalization (clicking "close" on the "Understanding Instant Personalization" pop-up, then see bottom of page), most of which will be enabled by default as a consequence of enabling apps.

Hope this helps.

comment:5 in reply to: ↑ 4 Changed 6 years ago by cobalt

  • Resolution set to invalid
  • Status changed from new to closed

@rtc.

Indeed, XMPP refused to work with other clients as well, and not a single debug entry seemed to point at what the problem was. At that point I realised it was an issue with Facebook, but nobody seemed to be able to figure out why that was the case.

Thank you so much for pointing that out. I fiddled a bit with the security settings and that solved it. Facebook changes their security settings too often, and you often have to mess around with those, and I must have changed that inadvertently, and not realised the consequences.

Things now work as expected.

Thanks you again.

I have marked the bug as invalid, as it's not a Pidgin problem.

comment:6 Changed 6 years ago by tmcmahon2

@rtc - have apps enabled but still can't, apparently, send messages over Jabber to Facebook.

@cobalt - What changes did you make? I'm not seeing anything obvious besides having apps enabled.

comment:7 Changed 6 years ago by rtc

cobalt, both you *and* the facebook friend you are sending messages to need to have apps enabled for jabber communication to work. So please make sure that the respective facebook friend(s) have enabled apps, too.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!