Opened 7 years ago

Last modified 6 years ago

#15091 new defect

"Invalid proxy settings" and Pidgin does not reconnect (XMPP, vpnc)

Reported by: jglick Owned by: EionRobb
Milestone: Component: unclassified
Version: 2.10.0 Keywords: proxy reconnect
Cc:

Description

Ubuntu 11.10 (all updates applied). I have an XMPP (over SSL) chat account which I always keep open. When I go on VPN using vpnc, setting my GNOME network proxy (HTTP & HTTPS specified) in "manual" mode, after a couple minutes Pidgin disconnects with the message "Invalid proxy settings - Either the host name or port number specified for your given proxy type is invalid". (I am not sure what is "invalid" about my settings since they work for other applications such as Chromium.) Annoying but not a serious problem; I click Close.

Later when I set the proxy back to "none" and close the VPN connection, the Buddy List window displays "<...name...> disconnected: Unable to establish SSL connection". Clicking Reconnect makes the message go away but does not actually reconnect. I have to go to the Account menu and reenable the account before Pidgin is back to normal. Pidgin ought to be reconnecting automatically once the network configuration is back to its previous state.

Log excerpts when the connection is initially lost:

(11:32:18) connection: Connection error on 0x7f261160e150 (reason: 0 description: Ping timed out) (11:32:18) account: Disconnecting account MYSELF/SERVICE (0x7f2611131bf0) (11:32:18) connection: Disconnecting connection 0x7f261160e150 (11:32:18) connection: Deactivating keepalive. (11:32:18) jabber: Sending (ssl) (MYSELF/SERVICE): </stream:stream> (11:32:18) connection: Destroying connection 0x7f261160e150 (11:32:23) util: Writing file accounts.xml to directory ~/.purple (11:32:23) util: Writing file ~/.purple/accounts.xml (11:32:23) util: Writing file blist.xml to directory ~/.purple (11:32:23) util: Writing file ~/.purple/blist.xml

Then when clicking Reconnect:

(11:32:45) autorecon: do_signon called (11:32:45) autorecon: calling purple_account_connect (11:32:45) account: Connecting to account MYSELF/SERVICE. (11:32:45) connection: Connecting. gc = 0x7f2611cedac0 (11:32:46) connection: Connection error on 0x7f2611cedac0 (reason: 4 description: Unable to establish SSL connection) (11:32:46) autorecon: done calling purple_account_connect (11:32:46) account: Disconnecting account MYSELF/SERVICE (0x7f2611131bf0) (11:32:46) connection: Disconnecting connection 0x7f2611cedac0 (11:32:46) connection: Destroying connection 0x7f2611cedac0

and when reenabling:

(11:32:51) util: Writing file accounts.xml to directory ~/.purple (11:32:51) util: Writing file ~/.purple/accounts.xml

Change History (1)

comment:1 Changed 6 years ago by rekkanoryo

  • Owner changed from rekkanoryo to EionRobb
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!