Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15220 closed defect (invalid)

Keyboard becomes non-responsive after changing status.

Reported by: shlomif Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.10.6 Keywords:
Cc: jantman

Description

Hi all,

I've built pidgin-2.10.6 from the source tar.gz using this command:

#!/bin/bash pref="$HOME/apps/pidgin-beta" ./configure --prefix="$pref" --disable-vv --disable-meanwhile --disable-nm --with-gconf-schema-file-dir="$pref/gconf/" --disable-schemas-install

(despite the fact that the prefix reads "pidgin-beta" this is pidgin-2.10.6).

After I built it and installed it, then Pidgin's keyboard input becomes non-responsive in the chat dialogues and elsewhere after I change my status to Away (and back), while the keyboard input works in all other X applications. I'm on Mageia Linux 3/Cauldron on an x86-64 Core i3 machine, and I tested it in a new UNIX user account and it also happens there.

Very annoying.

The only thing pidgin emits are the standard fontconfig warnings that are prevalent on latest Mageia cauldron.

Change History (12)

comment:1 Changed 5 years ago by de_jean_7777

I can confirm this. Same happens with Pidgin 2.10.5 on Fedora 17 (x64) on a Core i3, installed from Fedora repos. Changing status to anything will make keyboard input nonfunctional both on messages and status. Even shortcuts for switching tabs, clearing window and other do not work.

comment:2 Changed 5 years ago by de_jean_7777

One way to work around it is to change the input method (in the right-click context menu). It will respond until the next time a status is changed.

comment:3 Changed 5 years ago by JonnoN

Same here, pidgin-2.10.5-1.fc17.x86_64, all plugins are disabled. Changing the Input Method fixes it, even if choosing the same input method already selected (System (Simple)).

Desktop environment is gnome-shell-3.4.1-5.fc17.x86_64. Let me know if I can provide any further feedback.

comment:4 Changed 5 years ago by justauser

Almost same story here --- except....

For me it's pidgin-2.10.5-1.fc17.x86_64 as well, but I can change status back and forth with no issues. My keyboard becomes unresponsive only when I get a system notification via the gnome-plugin "Pidgin Conversation Integration Extension". I get a popup notify in the system tray, as well as a place to type chats in the system tray (courtesy of the plugin). However, the actual pidgin window won't accept input but as JonnoN says clicking the (already selected) System(Simple) works around the issue.

comment:5 Changed 5 years ago by shlomif

Thanks for the tip regarding the workaround of selecting the input method. It works great here. Nevertheless, this bug should be fixed.

comment:6 follow-up: Changed 5 years ago by shlomif

It seems I have run into a very similar bug (with the same workaround) in claws-mail on Mageia Linux 2. When I change my "From" E-mail address in a message I am sending, the keyboard becomes non-responsive until I use the "Input Method" trick. So it's possible that it is a bug in gtk+.

comment:7 in reply to: ↑ 6 Changed 5 years ago by shlomif

Replying to shlomif:

It seems I have run into a very similar bug (with the same workaround) in claws-mail on Mageia Linux 2. When I change my "From" E-mail address in a message I am sending, the keyboard becomes non-responsive until I use the "Input Method" trick. So it's possible that it is a bug in gtk+.

OK, now on Mageia Linux 3/Cauldron, the problem with Pidgin appears to have disappeared. I am still getting this problem with Claws-Mail running on Mageia Linux 2 from remote X and can try on Pidgin there in Mageia Linux 2 locally to see if it is still there.

Regards,

-- Shlomi Fish

comment:8 follow-up: Changed 5 years ago by shlomif

This bug still happens with Pidgin on Mageia 2 x86-64. I'm now trying to build the new gtk+ there ( 2.24.12 ). I'll report on my findings here.

comment:9 in reply to: ↑ 8 Changed 5 years ago by shlomif

Replying to shlomif:

This bug still happens with Pidgin on Mageia 2 x86-64. I'm now trying to build the new gtk+ there ( 2.24.12 ). I'll report on my findings here.

OK, upgrading gtk+2.0 to gtk+2.0-2.24.12-1.mga3.src.rpm seems to have solved this bug on Mageia Linux 2 as well. So it appears to be a gtk+2.0 regression.

comment:10 Changed 5 years ago by jantman

Confirmed also, Pidgin 2.10.5-1.fc17 on Fedora 17, KDE

comment:11 Changed 5 years ago by datallah

  • Resolution set to invalid
  • Status changed from new to closed

Closing because this is apparently a GTK+ bug.

comment:12 Changed 5 years ago by Umeaboy

For me it happens now and then as soon as I've logged in to a bunch of protocols.

https://bugs.mageia.org/show_bug.cgi?id=8483

Last edited 5 years ago by Umeaboy (previous) (diff)
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!