Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15224 closed defect (duplicate)

Freeze on loading large contact list from Gadu-Gadu

Reported by: linne Owned by: tomkiewicz
Milestone: Component: Gadu-Gadu
Version: 2.10.3 Keywords:
Cc:

Description (last modified by linne)

For some time now I'm having a huge problem with Pidgin on the Ubuntu. I have many contacts on my list (most of them from Gadu-Gadu protocol) and Pidgin hangs on startup. The number of contacts being loaded on the startup is around 170. The same happens if I have a clean install of Pidgin and try to download the contact list from the Gadu-Gadu server.

The interesting part here is that I'm using Pidgin on Windows XP as well, with the very same list of contacts, and the problem doesn't occur there.

I've been trying to resolve this for many weeks now, but I haven't found any helpful suggestions while searching on google. It seems as if no one else had this problem.

I tried to test it a little bit by removing some contacts from the blist.xml file and found out that if I limit the number of contacts to 113, everything works fine.

Running the Pidgin in debug mode (pidgin -d) and looking at the console it seems that at some point the Gadu-Gadu server just stops responding and Pidgin cannot handle this situation properly - it doesn't even timeout, it just hangs and stays like this forever.

I attach two log files from debug mode:

  • pidgin_hangs.log - this is startup log with 146 contacts, and in this case Pidgin hangs,
  • pidgin_loads.log - this is startup log with 113 contacts, and in this case Pidgin loads properly.

I removed all the personal data (ids, names etc.) and put placeholders ("<number>", "<username>" etc.) instead. Hopefully logs will be still easy to read.

Pidgin version: Pidgin 2.10.3 (libpurple 2.10.3)

System version: Linux 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 16:26:01 UTC 2012 i686 i686 i386 GNU/Linux

I would appreciate any suggestions on how to resolve this.

Attachments (2)

pidgin_hangs.log (197.5 KB) - added by linne 7 years ago.
This is startup log with 146 contacts, and in this case Pidgin hangs.
pidgin_loads.log (180.8 KB) - added by linne 7 years ago.
This is startup log with 113 contacts, and in this case Pidgin loads properly.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by linne

This is startup log with 146 contacts, and in this case Pidgin hangs.

Changed 7 years ago by linne

This is startup log with 113 contacts, and in this case Pidgin loads properly.

comment:1 Changed 7 years ago by linne

  • Description modified (diff)

comment:2 Changed 7 years ago by tomkiewicz

  • Owner set to tomkiewicz

Probably duplicate of #14305.

Please try disabling proxy (both for this account and for whole client):

  1. tools -> preferences -> proxy -> type: no proxy
  2. accounts -> manage -> select & modify -> proxy -> type: no proxy

Of course, tell if it helped.

comment:3 Changed 7 years ago by linne

Yes, it works! Setting proxy to None in account settings helped. Unbelievable, I've spent so many hours on that, and the solution was so close (and so simple...). Anyway, thanks :) I really need to describe this simple solution on the blog (in Polish).

comment:4 Changed 7 years ago by tomkiewicz

  • Milestone set to 3.0.0
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #14305.
Fix will be included in 3.0.0.

comment:5 Changed 7 years ago by Robby

  • Milestone 3.0.0 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!