Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#15226 closed defect (fixed)

Pidgin hangs after launching, killing impossible

Reported by: bartek Owned by: tomkiewicz
Milestone: 2.10.7 Component: Gadu-Gadu
Version: 2.10.6 Keywords:
Cc:

Description

I've been using pidgin for years. Now suddenly it stops working:

  • windows 7 x64
  • after lunching the window appears and also icon in the tray
  • it starts connecting (and it looks like with success)
  • window freezes, clicing on the icon in the tray doesn't work anytghink, the process can not be killed in the task manager or using other tools from sysinternals
  • I'v attached debug.log
  • I'v tried many times unistalling and installing again to latest version 2.10.6 - no success
  • I've uninstalled my antyvirus F-secure, UltraEdit?, VMware client - no success

Attachments (2)

debug.log (52.6 KB) - added by bartek 4 years ago.
debug3.log (11.3 KB) - added by bartek 4 years ago.

Download all attachments as: .zip

Change History (17)

Changed 4 years ago by bartek

comment:1 Changed 4 years ago by bartek

  • Component changed from unclassified to pidgin (gtk)
  • Owner rekkanoryo deleted

Changed 4 years ago by bartek

comment:2 Changed 4 years ago by bartek

I also attached another debug3.log when starting pidgin without logging: pigin -n. The results is the same, this time no window of pidgin, anly icon in the tray, when clicking on it, there is no response at all. Still can not kill pidgin.exe *32 process.

comment:3 Changed 4 years ago by deryni

  • Status changed from new to pending

What do you mean you cannot kill the process?

What happens exactly when pidgin is "frozen"?

Does Process Monitor (tracing pidgin and its process tree) say anything interesting about what is going on?

comment:4 Changed 4 years ago by bartek

  • Status changed from pending to new

in task manager, after confirming the question of killing the process, the process is still running, no other message appears. In the proces explorer of sysinternals there is an "error terminating process" "access denied" message window. Also pskill CLI tool says the same (below, the last polish message means "access denied"). Of course I run everything with admin priviliges and I succeed in killing other processes.

C:\win7-ap\sysinternals>pskill pidgin

PsKill? v1.13 - Terminates processes on local or remote systems Copyright (C) 1999-2009 Mark Russinovich Sysinternals - www.sysinternals.com

Unable to kill process pidgin: Odmowa dostŕpu.

comment:5 Changed 4 years ago by QuLogic

  • Component changed from pidgin (gtk) to Gadu-Gadu

GG is opening a ton of HTTP requests.

comment:6 Changed 4 years ago by QuLogic

  • Owner set to tomkiewicz

comment:7 Changed 4 years ago by bartek

Suddenly, I success in running and working with pidgin now!It happen after after Windows coming back from hibernation But another broken (impossible to kill) instance- process is still running from yesterday. But after restarting windows and launching "pidgin -n" - the process started, icon is in the tray, I can not kill it, I can not display window (nothing happen after clicking on the icon in the tray), I can not kill it (nothing happen in the task manager and also in Process explorer from sysinternals and while trying "bring to front" button in the process properties window there is an error message "no visible windows found for this process". Starting pidgin normally (while another pidgin -n is running)- gives the similiar problem - no window is displayed neither icon in the tray, but I can kill the process! The changes in my computer from yestarday: installing again f-secure and VMware client.

After another Windows restart, I can run and use the pidgin. After exiting and starting it again, the problem is like in the beginning - impossible to kill and use.

comment:8 Changed 4 years ago by tomkiewicz

Large amount of http requests is known problem - it's caused by improper avatars support implementation. This is rewritten in 3.0.0/gsoc branch.

However, we can disable avatars support for 2.x.x branch, to avoid such problems.

comment:9 Changed 4 years ago by tomkiewicz

Fixed in db3a62c8006c

comment:10 Changed 4 years ago by tomkiewicz

  • Milestone set to 2.10.7
  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 4 years ago by Tomasz Wasilczyk <tomkiewicz@…>

(In [db3a62c8006c]):
Gadu-Gadu: disable avatars support for buddies. Fixes #15226

comment:12 Changed 4 years ago by tomkiewicz

Ticket #15397 has been marked as a duplicate of this ticket.

comment:13 Changed 3 years ago by petesky

Good morning !

I use latest pidgin 2.10.7 under W8x32 and had no problems until now. Every day starting up pidgin it hangs at first attempt. I cannot close it trough taskman nor process explorer. Always get "Error terminating process: Access denied"

My datapath (storing logs, etc.) is set to mapped network drive, so i assume that network path is not full restored due logon process ?!

comment:14 Changed 3 years ago by tomkiewicz

Please, provide the logs. At this point, we cannot even assume, that problem is even connected with Gadu-Gadu protocol plugin.

comment:15 Changed 3 years ago by petesky

Sorry tomkiewicz , i'm not able to provide logs but i did not changed anything on windows (except regular updates). Pigin only works after one reboot. At first attempt, it hangs while logging into my accounts. When closing via taskman the process still remains in process list. Try to close it again will bring up something like "you try to close a process which has been already closed" but the tasbar icon is still present.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!