Opened 5 years ago

Closed 19 months ago

#15248 closed enhancement (duplicate)

New place for IRC channel website

Reported by: renatosilva Owned by: elb
Milestone: Component: IRC
Version: 2.10.6 Keywords:
Cc: ollie27

Description (last modified by renatosilva)

As explained by elb, Pidgin is now showing a "328: <URL>" for some IRC channels which have this set.

I suggest moving such information somewhere else, such as in the hint area:

http://developer.pidgin.im/raw-attachment/ticket/15248/Channel_website.png

In this case I think it could not be a link (as the hint area hides when you mouse over it), but it is not a link already anyway.

Attachments (3)

Channel_website.png (22.6 KB) - added by renatosilva 5 years ago.
Channel_website_fixed.png (9.2 KB) - added by renatosilva 3 years ago.
Channel_website_fixed.2.png (7 bytes) - added by renatosilva 3 years ago.
ignore this file

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by renatosilva

comment:1 Changed 5 years ago by renatosilva

  • Description modified (diff)

comment:2 Changed 5 years ago by renatosilva

  • Description modified (diff)

comment:3 Changed 5 years ago by renatosilva

Last edited 2 years ago by renatosilva (previous) (diff)

comment:4 Changed 5 years ago by renatosilva

For the record, it seems tooltip looks up additional fields to display from some hashtable, which could then be used to store 328 and possibly other numerics for displaying in that area.

comment:5 Changed 5 years ago by renatosilva

It seems messages are printed both linkified and with hard-coded HTML formatting, despite 'no linkify' and 'system message' control flags being specified by the changeset introducing this. It seems 'no log' overwrites the behavior of these other flags.

comment:6 Changed 3 years ago by renatosilva

Pidgin++ has a fix for this:

https://developer.pidgin.im/raw-attachment/ticket/15248/Channel_website_fixed.png

Changed 3 years ago by renatosilva

Changed 3 years ago by renatosilva

ignore this file

comment:7 Changed 19 months ago by chemistrydioxide

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15120.
Thank you very much for your report, renatosilva.

#15120 was puzzling me because I had no idea what the number 328 was supposed to mean.

comment:8 Changed 19 months ago by chemistrydioxide

  • Resolution duplicate deleted
  • Status changed from closed to new

comment:9 Changed 19 months ago by chemistrydioxide

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15100.
Oooops, sorry. I meant #15100, not #15120.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!