Opened 6 years ago

Closed 6 years ago

#15328 closed defect (worksforme)

Setting an alias with an accent for a new buddy doesn't save, crashes Pidgin when changing later

Reported by: rubin110 Owned by: rekkanoryo
Milestone: Component: XMPP
Version: 2.10.6 Keywords:
Cc:

Description

Two bugs stuck into one ticket, please let me know if I should split them.

Steps to reproduce:

  1. Open Pidgin 2.10.6 under Debian Sid 64bit
  2. Add/connect to a XMPP account, possibly on Google
  3. Add a buddy, filling in the alias field with a name that contains an accented letter, such as é
  4. Click Add
  5. Find the buddy in the buddy list
  6. Observe
  7. Right click on the buddy and select Alias
  8. Attempt to rename the buddy to anything, unicode or not
  9. Observe

Expected results:

  1. Buddy is added to the buddy list with the appropriate alias in place
  2. Buddy is renamed to the new alias

Actual results:

  1. Buddy is added to the buddy list with no alias, displayed with its address name
  2. Pidgin crashes

Here's a debug output from attempting to rename the buddy...

(20:21:18) jabber: jabber_roster_alias_change(): Aliased Renée LeVesque to Renée LeVesque
(20:21:18) jabber: jabber_roster_update(Renée LeVesque): [Source: local blist]: groups: Local
Pidgin 2.10.6 has segfaulted and attempted to dump a core file.

Change History (5)

comment:1 Changed 49 years ago by rubin110

  • Status changed from pending to new

comment:1 Changed 6 years ago by QuLogic

  • Component changed from unclassified to XMPP
  • Keywords accent unicode buddylist removed
  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

comment:2 Changed 6 years ago by rubin110

Sadly unable to reproduce bug. Please close out. Thanks.

P.s. Captchas makes birds cry.

comment:3 Changed 6 years ago by datallah

We'll close it for now, and we can reopen it if you can get a backtrace.

The captcha was unfortunately necessary to deal with the spam problems :(. It may be a bit heavy-handed - it's on my TODO list to look at making it only require one captcha per session to try to make it less painful.

comment:4 Changed 6 years ago by datallah

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!