Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15329 closed patch (fixed)

Please don't use -lgcrypt when building with GnuTLS

Reported by: beevvy Owned by: rekkanoryo
Milestone: 2.10.7 Component: unclassified
Version: 2.10.6 Keywords:
Cc:

Description

Pidgin doesn't use libgcrypt directly and yet it links to it through -lgcrypt when building with GnuTLS. Latest GnuTLS 2 releases can use nettle instead of libgcrypt, and GnuTLS 3 doesn't have libgcrypt support at all. Even when built with libgcrypt, GnuTLS doesn't require applications linking to it to explicitly link to libgcrypt (it would be the case only if it was using libgcrypt in its headers). So -lgcrypt can be safely removed from configure.ac.

I hope I'm not doing bad setting a milestone for this ticket. I didn't find any suggestions not to do so in TipsForBugReports.

Attachments (1)

pidgin-lgcrypt.patch (767 bytes) - added by beevvy 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by beevvy

comment:1 Changed 4 years ago by John Bailey <rekkanoryo@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In [eea4bbe04daa]):
Remove references to -lgcrypt from configure.ac. We don't directly use libgcrypt anywhere, and GnuTLS doesn't require us to link directly to it. Fixes #15329.

comment:2 Changed 4 years ago by John Bailey <rekkanoryo@…>

(In [32a57c474339]):
Credit where it's due. Refs #15329.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!