Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#15330 closed patch (duplicate)

Fix gtk_progress_set_percentage assertions during voice call

Reported by: haakon Owned by: Maiku
Milestone: Component: Voice and Video
Version: 2.10.6 Keywords: voice progressbar percentage assertion
Cc:

Description

At gtkmedia.c:level_message_cb(), level, which is a float percentage between 0.0 and 1.0, was multiplied by 5 prior setting as a progress bar value. This led to many warnings in debug log like this one:

Gtk: IA__gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

Patch removes the multiplication so the value is always between 0 and 1.

Attachments (1)

Fix-gtk_progress_set_percentage-assertion.patch (1.0 KB) - added by haakon 6 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #14426.

comment:2 Changed 3 years ago by Robby

  • Milestone Patches Needing Review deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!