Changes between Initial Version and Version 1 of Ticket #15381, comment 1


Ignore:
Timestamp:
11/01/12 17:37:04 (6 years ago)
Author:
csalgau
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #15381, comment 1

    initial v1  
    44Pidgin uses User-Agent: Mozilla/5.0.
    55Change this and you're home free.
     6
     7edit:
     8I forgot to specify where/what/when.
     9The problematic query is around
     10libpurple/protocols/yahoo/yahoo_aliases.c:yahoo_fetch_aliases()
     11as defined in libpurple/protocols/yahoo/libymsg.h
     12we currently have
     13#define YAHOO_CLIENT_USERAGENT "Mozilla/5.0"
     14This is not consistent with what Yahoo! does. Their HTTP(at least) user agent for querying Pager urls is the Mozilla/4.0 one. I found it hard coded in ft60.dll in the latest Yahoo! Messenger build.
     15Ads and other, newer links use the locally installed IE user agent.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!