Opened 6 years ago

Closed 2 years ago

#15491 closed defect (out of date)

Pidgin 2.10.6 yahoo connection refused

Reported by: ibrahim52 Owned by: sulabh.dev
Milestone: Component: Yahoo!/Yahoo! JAPAN
Version: 2.10.6 Keywords: connection refused
Cc: delcov

Description

Its been more than two weeks now, Since I am facing CONNECTION REFUSED error while connecting to yahoo accounts. For just yahoo I need to run virtual windows xp. Please fix it.

Change History (9)

comment:1 Changed 6 years ago by delcov

Here is a look at my debug logging for this exact issue, as it's been happening for myself as well in version 2.10.6 for the last couple of weeks.

(13:06:19) util: Writing file accounts.xml to directory C:\Users\dixona.PROTRANS\AppData\Roaming\.purple
(13:06:19) util: Writing file C:\Users\dixona.PROTRANS\AppData\Roaming\.purple\accounts.xml
(13:06:20) account: Connecting to account delcov.
(13:06:20) connection: Connecting. gc = 05474668
(13:06:20) util: requesting to fetch a URL
(13:06:20) dnsquery: Performing DNS lookup for vcs1.msg.yahoo.com
(13:06:20) dnsquery: IP resolved for vcs1.msg.yahoo.com
(13:06:20) proxy: Attempting connection to 98.136.48.32
(13:06:20) proxy: Connecting to vcs1.msg.yahoo.com:80 with no proxy
(13:06:20) proxy: Connection in progress
(13:06:20) proxy: Connecting to vcs1.msg.yahoo.com:80.
(13:06:20) proxy: Connected to vcs1.msg.yahoo.com:80.
(13:06:20) util: request constructed
(13:06:20) util: Response headers: 'HTTP/1.1 200 OK

Content-Type: text/plain; charset=utf-8

Cache-Control: max-age=0, must-revalidate

Expires: Sun, 10 Jun 2007 12:01:01 GMT

Content-Length: 46

Connection: close

Warning: 111 SecurityGateway "Revalidation failed"

Age: 0

Date: Mon, 28 Jan 2013 18:06:19 GMT



'
(13:06:20) util: parsed 46
(13:06:20) yahoo: Got COLO Capacity: 1
(13:06:20) yahoo: Got CS IP address: 98.136.48.112
(13:06:20) dnsquery: Performing DNS lookup for 98.136.48.112
(13:06:20) dnsquery: IP resolved for 98.136.48.112
(13:06:20) proxy: Attempting connection to 98.136.48.112
(13:06:20) proxy: Connecting to 98.136.48.112:5050 with no proxy
(13:06:20) proxy: Connection in progress
(13:06:21) proxy: Connecting to 98.136.48.112:5050.
(13:06:21) proxy: Error connecting to 98.136.48.112:5050 (Connection refused.).
(13:06:21) proxy: Connection attempt failed: Connection refused.
(13:06:21) connection: Connection error on 05474668 (reason: 0 description: Unable to connect: Connection refused.)
(13:06:21) account: Disconnecting account delcov (02651640)
(13:06:21) connection: Disconnecting connection 05474668
(13:06:21) jabber: jabber_actions: have pep: NO
(13:06:21) connection: Destroying connection 05474668
(13:06:25) util: Writing file accounts.xml to directory C:\Users\dixona.PROTRANS\AppData\Roaming\.purple
(13:06:25) util: Writing file C:\Users\dixona.PROTRANS\AppData\Roaming\.purple\accounts.xml
Last edited 6 years ago by Robby (previous) (diff)

comment:2 Changed 6 years ago by ibrahim52

In earlier version there was an option to edit PAGE SERVER address but now there is not even that anymore.

comment:3 follow-up: Changed 6 years ago by ibrahim52

Wow, its so INSTANT. Thanks to the developers of PIDGIN. The problem is solved, hopefully it never comes back again. Its most amazing IM client so far proven with best support.

comment:4 in reply to: ↑ 3 Changed 6 years ago by delcov

Replying to ibrahim52:

Wow, its so INSTANT. Thanks to the developers of PIDGIN. The problem is solved, hopefully it never comes back again. Its most amazing IM client so far proven with best support.

How was this resolved? I would like to know so that I can implement the change as well, and so that it can be documented for other users to see.

comment:5 Changed 6 years ago by ibrahim52

I am sorry I guess I was over reacting thinking that it was solved through the developers but it worked only for a while and it is back again with the same issue. Sorry dude.

comment:6 Changed 6 years ago by datallah

It looks like the issue may be that one of the yahoo pager servers in the rotation isn't accepting connections.

comment:7 Changed 6 years ago by rekkanoryo

The setting to control the pager server was removed because when I implemented the new login method that uses HTTPS, I found that the login server returns a specific pager server to connect to. When using the new login method, you can't just arbitrarily pick a pager server--you're supposed to use the one given to you by the login process. The login process chooses the server for you to provide load balancing.

I'm inclined to agree with Daniel. It looks like the server being given in the login response is not responding to YMSG connections like it's supposed to. It's either that or the login protocol changed yet again, and this particular server only speaks the new method (please, no...Yahoo protocol changes are a pain). Of course, a third possibility is a network firewall preventing the outbound connection on port 5050, but I doubt the connection to login.yahoo.com would have gotten as far as it did if the firewall was the culprit.

comment:8 Changed 6 years ago by ibrahim52

Thank you Daniel & rekkanoryo. The issue seems to be solved again, I am able to login to my yahoo account for now. Lets see how long it works. Hopefully there should be any more issues. Thanks once again to both.

comment:9 Changed 2 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all yahoo bugs since the yahoo implementation in pidgin no longer works, and the new protocol is completely different. See the funyahoo++ third party plugin for an alternative.

If this still applies to other parts of pidgin, leave a comment and we'll reopen.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!