Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#15509 closed defect (invalid)

wrong username sent for irc

Reported by: sdh Owned by: elb
Milestone: Component: IRC
Version: 2.10.6 Keywords:
Cc:

Description

since today pidgin (on kubuntu, from pidgin ppa, many plugins installed) is sending sdsh1 even when my username is sdsh. Thus i get a notice for sdsh@… (irc): sdsh1 is not a registered nickname. I've tried deleting the account and creating a new one. What should i do?

Change History (10)

comment:1 Changed 49 years ago by sdh

  • Status changed from pending to new

comment:1 Changed 6 years ago by datallah

  • Status changed from new to pending

The most likely cause for this is that a user with the nickname of "sdsh" is already connected, so pidgin falls back to appending "1" in order to make a unique username.

The debug log (Help->Debug Window) can confirm this.

comment:2 Changed 6 years ago by sdh

As sdsh is my registered account, its unlikely that username already exists. On connecting to irc, I get the following messages:

(00:49:33) proxy: Connected to irc.freenode.com:6667.
(00:49:33) irc: Got a NOTICE on *, which does not exist
(00:49:33) irc: Got a NOTICE on *, which does not exist
(00:49:33) irc: Got a NOTICE on *, which does not exist
(00:49:43) irc: Got a NOTICE on *, which does not exist
(00:49:43) irc: Unrecognized message: :calvino.freenode.net 001 sdsh1 :Welcome to the freenode Internet Relay Chat Network sdsh1
(00:49:43) irc: Unrecognized message: :calvino.freenode.net 002 sdsh1 :Your host is calvino.freenode.net[213.92.8.4/6667], running version ircd-seven-1.1.3
(00:49:43) irc: Unrecognized message: :calvino.freenode.net 003 sdsh1 :This server was created Sun Dec 4 2011 at 14:42:47 CET
(00:49:43) irc: Unrecognized message: :calvino.freenode.net 004 sdsh1 calvino.freenode.net ircd-seven-1.1.3 DOQRSZaghilopswz CFILMPQbcefgijklmnopqrstvz bkloveqjfI
(00:49:43) pidgin-libnotify: event_connection_throttle() called
(00:49:43) connection: Activating keepalive.
(00:49:43) irc: Unrecognized message: :calvino.freenode.net 252 sdsh1 37 :IRC Operators online

Does this help?

Last edited 6 years ago by Robby (previous) (diff)

comment:3 Changed 5 years ago by thufirh

This is a bug, IMHO. pidgin should *not* append a 1 to the nick, it should keep trying until it fails. in freenode, you can't join certain channels if the registration fails, so that depends on sending the correct nickname to nickserv. I believe this is the same problem, could be wrong.

comment:4 Changed 5 years ago by datallah

Ticket #15757 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by datallah

  • Resolution set to invalid
  • Status changed from new to closed

This behavior is not a bug, it's by design.

If your nickname is in use (either ghosted by old session of yours or used by another user), you need to be able to connect with an alternate name and run through the appropriate steps to reclaim your nickname.

comment:6 Changed 5 years ago by thufirh

the problem is that it's pidgin itself which creates this old session, thus creating this problem to begin with. It may be by design that if an old session exists, then pidgin tries variations -- that's fine. The problem here is that on a regular basis pidgin itself creates these connection problems and *then* doesn't handle it gracefully. Surely that aspect is not by design.

comment:7 Changed 5 years ago by datallah

There are any number of scenarios that can cause a ghosted session - usually it's a "unplanned" disconnection (e.g. some sort of network disruption). If there's something that Pidgin is doing wrong to cause unclean disconnections, then we'd be interested to know about it, but that's probably not the case.

comment:8 follow-up: Changed 5 years ago by thufirh

Perhaps the problem lies in the way Pidgin handles unplanned disconnections? Maybe it should handle them differently -- I don't have enough knowledge of pidgin to say exactly what happens step by step, only that the result is not what the user (me and at least one other) expects. I would be glad to vote on a bug to fix the way pidgin handles unplanned disconnections, if that's the problem.

comment:9 in reply to: ↑ 8 Changed 5 years ago by Robby

Try a different client than Pidgin, and you will probably find it behaves the same.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!