Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#15520 closed defect (fixed)

tcl.dll causes startup crash

Reported by: polytekpatrick Owned by: datallah
Milestone: 2.10.8 Component: winpidgin (gtk)
Version: 2.10.7 Keywords: tcl, tcl.dll, crash
Cc: gbmr

Description

I updated pidgin to 2.10.7 from 2.10.6 and found that it crashed immediately at startup. Same thing even after a fresh install with no plugins enabled. Deleting the file plugins/tcl.dll fixed the problem. My machine has ActiveTcl? 8.4.9.0 installed (required by my work, so not something I can change). I figured out it was tcl.dll causing the crash by the pidgin.RPT and debug log (both attached).

Attachments (2)

debug.log (5.8 KB) - added by polytekpatrick 4 years ago.
pidgin.RPT (755 bytes) - added by polytekpatrick 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by polytekpatrick

Changed 4 years ago by polytekpatrick

comment:1 Changed 4 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from rekkanoryo to datallah

Looks like it's crashing in the stack-smashing protection code (which may mean that there's some sort of stack bug in the plugin initialization).

comment:2 Changed 4 years ago by Daniel Atallah <datallah@…>

  • Milestone set to 2.10.7
  • Resolution set to fixed
  • Status changed from new to closed

(In [81c1f235dce6]):
tcl: Fix dynamically loaded Tcl/Tk functions to be called using cdecl calling conventions.

Fixes #15520

Last edited 4 years ago by datallah (previous) (diff)

comment:3 Changed 4 years ago by datallah

  • Milestone changed from 2.10.7 to 2.10.8

comment:4 Changed 3 years ago by gbmr

Sorry for bringing up old conversation, but this issue reproduced on my PC too. Currently I just removed tcl.dll file and pidgin works OK for me. But I can't understand, why it works fine in 2.10.6. There is same CALLBACK function call style but it don't crash. What was changed in 2.10.7 to make it crashing?

Thanks

comment:5 Changed 3 years ago by datallah

The change in 2.10.7 was to the version of gcc that's being used (which has a different default calling convention).

comment:6 Changed 3 years ago by datallah

Ticket #15834 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!