Opened 6 years ago

Closed 6 years ago

#15525 closed defect (worksforme)

Pidgin disconnecting locally

Reported by: mike.norris Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.7 Keywords: Server has closed the connection
Cc:

Description (last modified by Robby)

Greetings,

I've been wrestling with a problem for the last few days. We have 2 new users, but they keep getting "Server has closed the connection" errors. I've been doing everything I can on our Openfire server, but the problem persists. I realized that I can re-create their account on my machine and log in as them just fine, but when I attempt to log in on theirs, I get the disconnect error. Here is where the error is in the debug:

(09:52:46) jabber: Recv (ssl)(1): <
(09:52:46) jabber: Recv (ssl)(368): iq type="error" id="purplee505180" to="USER@OURSERVERNAME/98ad7277"><pubsub xmlns="http://jabber.org/protocol/pubsub"><publish node="http://jabber.org/protocol/tune"><item><tune xmlns="http://jabber.org/protocol/tune"/></item></publish></pubsub><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>
(09:52:46) jabber: Unhandled IQ with id purplee505180
(09:52:46) connection: Connection error on 05599170 (reason: 0 description: Server closed the connection)
(09:52:46) account: Disconnecting account USER@OURSERVERNAME/ (02141DE8)
(09:52:46) connection: Disconnecting connection 05599170
(09:52:46) connection: Deactivating keepalive.
(09:52:46) jabber: Sending (ssl) (USER@OURSERVERNAME/98ad7277): </stream:stream>
(09:52:46) connection: Destroying connection 05599170
(09:52:50) util: Writing file accounts.xml to directory C:\Users\USER\AppData\Roaming\.purple
(09:52:51) util: Writing file C:\Users\USER\AppData\Roaming\.purple\accounts.xml
(09:52:52) util: Writing file blist.xml to directory C:\Users\USER\AppData\Roaming\.purple
(09:52:52) util: Writing file C:\Users\USER\AppData\Roaming\.purple\blist.xml

Change History (6)

comment:1 Changed 6 years ago by Robby

  • Description modified (diff)

comment:2 Changed 6 years ago by datallah

  • Component changed from unclassified to XMPP
  • Owner changed from rekkanoryo to deryni

Based on the log, the server is disconnecting the client. It may be helpful to look at the server logs.

The previous "error" stanza is not really an error, just that the server doesn't know how to handle the "Now Playing" (XEP-0118) message. This shouldn't be a problem, the server should just ignore it along with any other extensions it doesn't know about.

If you're using an old version of openfire, you may need to upgrade, I vaguely remember there being issues with the server disconnecting due to unrecognized stanzas.

comment:3 Changed 6 years ago by darkrain42

It would also be useful to review a full debug log. It's very likely that the stanza that comes *after* the ID purplee505180 request is the one that's causing the server to close uncleanly.

comment:4 Changed 6 years ago by darkrain42

  • Status changed from new to pending

comment:5 Changed 6 years ago by mike.norris

  • Status changed from pending to new

The "Now Playing" feature was indeed the cause. We have a few users that use Adium, and the iTunes "now playing" status was causing certain users to not be able to connect. I was able to track down who it was by watching their debug. As the groups populated, it would list user by user. Once it came to someone with the "Now Playing" active, it would kick the user out. I was able to go around and disable this status.

Problem resolved, thank you for your assistance.

comment:6 Changed 6 years ago by datallah

  • Resolution set to worksforme
  • Status changed from new to closed

I think you probably should look at upgrading the server as it should be able to handle these stanzas, but that's not really a pidgin issue :)

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!