Opened 6 years ago

Closed 6 years ago

Last modified 14 months ago

#15579 closed patch (patch_rejected)

IRC SASL login fails when nickname is taken

Reported by: andy753421 Owned by: elb
Milestone: Component: IRC
Version: 2.10.7 Keywords: irc sasl
Cc: grawity

Description

Freenode expects the SASL login name to be the regular username, not the current nickname.

Attachments (1)

fix-sasl-irc-login.patch (2.1 KB) - added by andy753421 6 years ago.
Fixes sasl login when nickname is taken

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by andy753421

Fixes sasl login when nickname is taken

comment:1 Changed 6 years ago by elb

I mistakenly marked this duplicate, it is subtly different.

Can I have a real name and email address for ChangeLog and the commit when I apply this patch?

comment:2 Changed 6 years ago by Robby

  • Type changed from defect to patch

comment:3 Changed 6 years ago by grawity

Will this patch allow, for example, configuring Pidgin to use a nickname "grawity_work" but still log into the "grawity" account?

It looks like it is expecting the primary nickname to always be the same as the services account.

comment:4 Changed 6 years ago by elb

It does not, which is why I unmarked it as duplicate of #15451. This addresses a different (though related) problem.

comment:5 Changed 6 years ago by andy753421

  • Resolution set to patch_rejected
  • Status changed from new to closed

This will be fixed as part of #15451

comment:6 Changed 14 months ago by isleshocky77

It's now 5 years later and #15451 was never merged and address and this patch was closed when the problem still exists. Could we reopen this issue and address it?

User Story still happening

John Smith is logged in to irc.freenode.net using nick john.smith on desktop compter John Smith goes on road with laptop and attempts to login to irc.freenode.net using nikc john.smith on laptop and is told his password is incorrect by pidgin

If John Smith logs out is desktop computer before leaving, then he has no problem logging in with his laptop.

This is when using sasl which is now required many times based on ip address (e.g. verizon wireless network)

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!