Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#15623 closed defect (duplicate)

IRC join delay needs to be finally addressed

Reported by: jxt379 Owned by: elb
Milestone: Component: IRC
Version: 2.10.7 Keywords: auto join nickserv delay
Cc:

Description

Problem: Using <2.10.7 clients do not allow buddy pounces time before auto-joining channels.

Solution: A few seconds delay between connection to the ircd and autojoin to allow pounces time to send password to ANY version of services/ircd. No matter what the name; NS/Nickserv/X/Q/etc can be edited with a pounce. This is not a concern.

Addendum: Your site explicitly states no support for 3rd party plugins, and links to non-existent IRC-plugins on broken websites (see FAQ and prev tickets - guifications.org) IRCHelper and/or IRCMore are buggy, old, unsupported and also the site hosting has been down for months.

All we ask is please consider this simple request, and a myriad of tickets from 4 years old to today can be classed as dealt with and never to be heard of again.

This only has to be done once, on connection to the IRC server. This solution will make Pidgin-IRC 3rd party plugin free and usable. It's a real shame the work that has gone into supporting IRC, and 99% is done extremely well. Just a few seconds is all that we ask.

Thank you.

Change History (2)

comment:1 Changed 6 years ago by elb

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11089.
This is just a duplicate of #11089 with additional FSUES.

This takes more than a few seconds. Someone with this problem should put their money where their mouth is and submit a patch. Otherwise, I'll get to it when I get to it -- but I have way more things on my plate than time to do them in.

comment:2 Changed 6 years ago by Robby

  • Milestone 2.10.8 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!