Changes between Initial Version and Version 2 of Ticket #15624


Ignore:
Timestamp:
05/05/13 13:26:27 (6 years ago)
Author:
ashmew2
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #15624

    • Property Type changed from defect to patch
  • Ticket #15624 – Description

    initial v2  
    1 While compiling from source , the configure script gives syntax errors when it tries to guess the version of python on systems where the default python binary is python 3.x instead of the required python 2.x. In systems with both python2.x and python3.x installed, the python2 interpreter is usually named python2 instead of python. If python2 is not installed and python is python3.x, the make step fails with syntax errors. This is to prevent the make step from failing and detect if Python 2.x is available even if it is not the default python on the system.
     1While compiling from source , the configure script gives syntax errors when it tries to guess the version of python on systems where the default python binary is python 3.x instead of the required python 2.x.
     2
     3In order to make it successfully through compilation, the .py files need to be modified so that they are compatible with both versions of Python. Also, the configure.ac script should be edited to only check for the existence of Python.h and not worry about what the major version of Python is.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!