Opened 6 years ago

Closed 6 years ago

#15661 closed defect (duplicate)

Pidgin freezes on reconnection after lost connection

Reported by: white_gecko Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.10.7 Keywords:
Cc:

Description

My pidgin always crashes, when it tries to reconnect after I lost my internet connection. The UI freezes and I have to force close it. (in rare cases it doesn't crash)

Here is the end of my debug.log:

(11:06:19) network: Got StateChange from NetworkManager: 20.
(11:06:19) account: Disconnecting account me@jabber.abc.de/pc (0x7f2a4080b400)
(11:06:19) connection: Disconnecting connection 0x7f2a416dae20
(11:06:19) connection: Deactivating keepalive.
(11:06:19) jabber: Sending (ssl) (me@jabber.abc.de/pc): </stream:stream>
(11:06:19) connection: Destroying connection 0x7f2a416dae20
(11:06:19) network: Got StateChange from NetworkManager: 40.
(11:06:24) util: Writing file blist.xml to directory /home/me/.purple
(11:06:24) util: Writing file /home/me/.purple/blist.xml
(11:06:24) util: Writing file accounts.xml to directory /home/me/.purple
(11:06:24) util: Writing file /home/me/.purple/accounts.xml
(11:06:31) network: Got StateChange from NetworkManager: 70.
(11:06:31) autorecon: do_signon called
(11:06:31) autorecon: calling purple_account_connect
(11:06:31) account: Connecting to account me@jabber.abc.de/pc.
(11:06:31) connection: Connecting. gc = 0x7f2a40d2e300

Attachments (1)

pidgin-backtrace.log (4.2 KB) - added by white_gecko 6 years ago.
Pidgin backtrace after freeze

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

comment:2 Changed 6 years ago by white_gecko

  • Status changed from pending to new
  • Summary changed from Pidgin crashes on reconnection after lost connection to Pidgin freezes on reconnection after lost connection

I can't get a stack trace. Because it doesn't really crash but rather freezes and than I have to force quit it.

(gdb) run
Starting program: /usr/bin/pidgin 
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe10c6700 (LWP 21570)]
bt full
[Thread 0x7fffe10c6700 (LWP 21570) exited]

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
(gdb) bt full
No stack.

comment:3 Changed 6 years ago by datallah

  • Status changed from new to pending

Before you you kill it, get a backtrace - that'll tell where it's hanging.

Changed 6 years ago by white_gecko

Pidgin backtrace after freeze

comment:4 follow-up: Changed 6 years ago by white_gecko

  • Status changed from pending to new

Attachment (pidgin-backtrace.log) added by ticket reporter.

comment:5 in reply to: ↑ 4 Changed 6 years ago by white_gecko

Replying to white_gecko:

Attachment (pidgin-backtrace.log) added by ticket reporter.

[ctrl]+[c] in gdb did the trick :-)

comment:6 Changed 6 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15493.
You're running into the glib bug referenced in #15493.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!