Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#15742 closed enhancement (wontfix)

Pidgin Im window forking up when sending message from java program

Reported by: sasi Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.10.7 Keywords: pidgin dbus IM-Window
Cc:

Description

Hi..

I am trying to integrate pidgin-dbus with my java project. While sending message from java program using purple interface & dbus, IM window is forking up which isn't required.

Is it possible to send instant messages from background without forking up the chat window or can you provide any other solutions to avoid this.

Change History (4)

comment:1 Changed 6 years ago by datallah

  • Status changed from new to pending

What exactly is happening that you think is suboptimal? What does "forking up" specifically mean?

comment:2 Changed 6 years ago by sasi

  • Status changed from pending to new

Forking up means chat window is popping up when sending message from program like when we click on the contact in IM, the chat window is pops up which enables us to chat.

I am using PurpleConvImSend?(IM, msg) method in PurpleInterface? to send messages.

Any suggestions to avoid this.

comment:3 Changed 6 years ago by datallah

  • Resolution set to wontfix
  • Status changed from new to closed

Pidgin is a GUI IM client - it isn't designed to be a conduit for the background sending of messages by other programs.

The behavior you're seeing is by design.

comment:4 Changed 6 years ago by sasi

You are right pal. Pidgin is a GUI IM client. But it is providing dbus objects & interfaces for developers allowing them to send (or) receive messages and notifications etc, isn't it? (or) am i not using it for the purpose what the pidgin IM developers intended to be.

Thanks..

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!