Opened 6 years ago

Closed 6 years ago

#15757 closed defect (duplicate)

when nick registration fails, do not append a "1"

Reported by: thufirh Owned by: rekkanoryo
Milestone: Component: IRC
Version: 2.10.3 Keywords:
Cc:

Description

Conversation with NickServ? on Tue 17 Sep 2013 04:43:10 AM PDT: (04:43:10 AM) NickServ?: (notice) thufir?1 is not a registered nickname. ... (04:44:07 AM) NickServ?: (notice) thufir?1 is not a registered nickname.

However, that's not my nick at all:

thufir <at> dur:~$ thufir <at> dur:~$ head .purple/accounts.xml <?xml version='1.0' encoding='UTF-8' ?>

<account version='1.0'>

<account>

<protocol>prpl-irc</protocol> <name>thufir? <at> irc.freenode.net</name> <password>*&$##% <at> #$# <at> </password> <alias>thufir</alias> <statuses>

<status type='available' name='Available'

active='true'> thufir <at> dur:~$

see also:

http://article.gmane.org/gmane.comp.gnome.pidgin.user/13751

pidgin is sending the wrong data to freenode nickserv, different from what's in the config files.

according to LotR on irc this is due to freenode being weird. When there's a connection problem then pidgin appends a 1 to the nick and tries again.

I differ, if I configure with a particular nick, that's the one I want to use...

seems an odd behaviour which I would like to disable. every x seconds pidgin should try to register the correct nick until success or x number of attempts...

the problem is that you cannot then join channels which require registration.

Change History (2)

comment:1 Changed 6 years ago by thufirh

probably a duplicate of 15509

comment:2 Changed 6 years ago by datallah

  • Component changed from unclassified to IRC
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15509.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!